surpport seeking the recorded video
[vuplus_openembedded] / recipes / libdisplaymigration / libdisplaymigration_0.99.bb
1 LICENSE = "LGPL"
2 DESCRIPTION = "Gtk+ display migration library (dummy version)"
3 DEPENDS = "gtk+"
4 SECTION = "gpe"
5 PRIORITY = "optional"
6 PR = "r0"
7
8 inherit pkgconfig gpe
9
10 SRC_URI += "file://makefile-fix.patch;patch=1"
11
12 headers = "displaymigration.h auth.h crypt.h"
13
14 do_install() {
15         oe_runmake PREFIX=${prefix} DESTDIR=${D} install
16         oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
17 }
18
19 do_stage () {
20         oe_libinstall -so libdisplaymigration ${STAGING_LIBDIR}
21
22         mkdir -p ${STAGING_INCDIR}/libdisplaymigration
23         for h in ${headers}; do
24                 install -m 0644 ${S}/libdisplaymigration/$h ${STAGING_INCDIR}/libdisplaymigration/${h}
25         done
26 }