surpport seeking the recorded video
[vuplus_openembedded] / recipes / libaio / libaio_0.3.103.bb
1 # libaio .bb build file
2 # Copyright (C) 2005-2006, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see /COPYING)
4
5 DESCRIPTION="Asynchronous input/output library that uses the kernels native interface"
6 HOMEPAGE="https://rhn.redhat.com/errata/RHBA-2005-085.html"
7 LICENSE="GPL"
8
9 SRC_URI="http://search.belnet.be/packages/lineox/4.0/updates/SRPMS/${P}-3.src.rpm \
10 file://${P}-more-arches.patch;patch=1"
11
12 S="${WORKDIR}/${P}"
13
14 FILES_${PN} = "/usr"
15
16 inherit kernel-arch
17
18 DEPENDS_append = " rpm2cpio-native"
19
20 do_unpack() {
21
22         if ! test -f libaio-${PV}.tar.gz ; then
23                 rpm2cpio.pl ${DL_DIR}/${P}-3.src.rpm | cpio -i --make-directories
24                 tar xzvf libaio-${PV}.tar.gz
25         fi
26 }
27
28 do_stage () {
29         #make install prefix='${STAGING_DIR_TARGET}${layout_prefix}'
30         install -D -m 644 src/libaio.h ${STAGING_INCDIR}/libaio.h
31         oe_libinstall -so -C src libaio ${STAGING_LIBDIR}
32
33 }
34
35 do_install () {
36         make install prefix='${D}/usr'
37 }