surpport seeking the recorded video
[vuplus_openembedded] / recipes / konqueror / konqueror-embedded_20070316.bb
1 DESCRIPTION = "KDE Web Browser Konqueror, QtE based Palmtop Environments Edition"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 HOMEPAGE = "http://www.konqueror.org/"
5 DEPENDS = "openssl libpcre virtual/libqte2 dcopidl-native dcopidl2cpp-native"
6 LICENSE = "LGPL GPL"
7 PR = "r7"
8
9 # this Konqueror needs the KDEDIR set and the font helvetica installed on the target
10
11 inherit autotools
12
13 SRC_URI = "http://www.basyskom.de/uploads/175/37/kdenox_snapshot_qt2_20070316.tar.bz2 \
14            file://dont-use-kde-config.patch;patch=1 \
15            file://konqe_new_opie.patch;patch=1 \
16            file://konqe-kapplication.patch;patch=1 \
17            file://fix_configure.patch;patch=1 \
18            file://fix_acinclude.patch;patch=1 \
19            file://fix_KDE_LDPATH_HACK.patch;patch=1 \
20            "
21 S = "${WORKDIR}/kdenox"
22
23 export QMAKE = "${STAGING_BINDIR_NATIVE}/qmake"
24 export MOC = "${STAGING_BINDIR_NATIVE}/moc"
25 export UIC = "${STAGING_BINDIR_NATIVE}/uic"
26 #export exec_prefix = "${palmtopdir}"
27 #export CXXFLAGS = "-fexceptions -frtti -DKJS_VERBOSE=1 -DQT_THREAD_SUPPORT -DQ_OS_UNIX -DQT_NO_DOM -DENABLE_BOOKMARKS"
28 export CXXFLAGS = "-fexceptions -frtti -DKJS_VERBOSE=1 -DQT_THREAD_SUPPORT -DQ_OS_UNIX -DENABLE_BOOKMARKS"
29 export PCRE_CONFIG = "invalid"
30 # uncomment this for a static build
31 # EXTRAFLAGS = "-lts"
32 # EXTRAFLAGS_c7x0 = "-lts -laticore"
33 export EXTRA_OEMAKE = "EXTRA_LDFLAGS='${EXTRAFLAGS}'"
34
35 EXTRA_OECONF = '--prefix=${palmtopdir} \
36         --exec-prefix=${palmtopdir} \
37 #       --includedir=${STAGING_INCDIR} \
38         --includedir=/usr/include \
39         --with-extra-includes=${STAGING_INCDIR} \
40         --with-extra-libs=${STAGING_LIBDIR} \
41         --with-qtopia-dir=${OPIEDIR} \
42         --with-ssl-version=0.9.7e \
43         --with-ssl-dir=${STAGING_DIR_HOST}${layout_exec_prefix} \
44         --with-qt-includes=${STAGING_DIR_HOST}/qt2/include \
45         --with-qt-libraries=${STAGING_DIR_HOST}/qt2/lib \
46         --with-qt-dir=${QTDIR} \
47         --enable-fontsubs \
48         --with-konq-tmp-prefix=/tmp/kde-cache \
49 #       --enable-static \
50         --disable-static \
51         --enable-shared \
52         --disable-debug \
53         --with-gui=road \
54         --with-ipv6-lookup=no \
55         --without-xinerama \
56 #       --disable-scrollbars \
57         --disable-selection \
58         --disable-bookmarks \
59         --with-javascript=static \
60         --enable-debug=yes \
61         --disable-printing \
62 #       --enable-pcre \
63         --disable-pcre \
64         --without-arts \
65         --enable-jshostext \
66         --disable-selection \
67         --enable-final \
68         --enable-qt-embedded \
69         --enable-rtti-embedded \
70         --enable-mt \
71         --enable-qpe \
72         --enable-qt-mt \
73         --enable-fwnewepg=yes \
74         --enable-embedded '
75
76 do_configure_prepend() {
77         cd ${S}
78         if ! test -L admin
79         then
80             ln -s ../kdelibs/admin admin
81         fi
82 }
83
84 do_compile_prepend() {
85         perl admin/am_edit
86 }
87
88 do_install_append() {
89         install -d ${D}${palmtopdir}/apps/Applications
90         install -m 0644 ${FILESDIR}/konqueror.desktop ${D}${palmtopdir}/apps/Applications/
91         install -d ${D}${palmtopdir}/pics/konqueror
92         install -m 0644 ${FILESDIR}/konqueror.png ${D}${palmtopdir}/pics/konqueror/
93         mv ${D}${palmtopdir}/bin ${D}${bindir}
94         mv ${D}${bindir}/konqueror ${D}${bindir}/konqueror.bin
95         { echo '#!/bin/sh' ; echo "KDEDIR=/usr exec ${bindir}/konqueror.bin" ; } > ${D}${bindir}/konqueror
96         chmod 0755 ${D}${bindir}/konqueror
97 }
98
99 FILES_${PN} = "${palmtopdir} ${datadir} ${bindir}/konqueror* ${libdir}/libkonq*"