surpport seeking the recorded video
[vuplus_openembedded] / recipes / konqueror / konqueror-embedded_20060404.bb
1 DESCRIPTION = "KDE Web Browser Konqueror, QtE based Palmtop Environments Edition"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 HOMEPAGE = "http://www.konqueror.org/"
5 DEPENDS = "openssl libpcre virtual/libqte2 dcopidl-native dcopidl2cpp-native"
6 LICENSE = "LGPL GPL"
7 PR = "r3"
8
9 # this Konqueror needs the KDEDIR set and the font helvetica installed on the target
10
11 inherit autotools
12
13 SRC_URI = "svn://anonsvn.kde.org/home/kde/tags/KDE/3.5.1;module=kdelibs;date=${PV} \
14            svn://anonsvn.kde.org/home/kde/trunk;module=kdenox;date=${PV} \
15            file://gcc4.patch;patch=1 \
16            file://dont-use-kde-config.patch;patch=0"
17 # uncomment this for a static build
18 #          file://inject-extraflags.patch;patch=1"
19 S = "${WORKDIR}/kdenox"
20
21 export QMAKE = "${STAGING_BINDIR_NATIVE}/qmake"
22 export MOC = "${STAGING_BINDIR_NATIVE}/moc"
23 export UIC = "${STAGING_BINDIR_NATIVE}/uic"
24 #export exec_prefix = "${palmtopdir}"
25 export CXXFLAGS = "-fexceptions -frtti -DKJS_VERBOSE=1 -DQT_THREAD_SUPPORT -DQ_OS_UNIX -DQT_NO_DOM -DENABLE_BOOKMARKS"
26 export PCRE_CONFIG = "invalid"
27 # uncomment this for a static build
28 # EXTRAFLAGS = "-lts"
29 # EXTRAFLAGS_c7x0 = "-lts -laticore"
30 export EXTRA_OEMAKE = "EXTRA_LDFLAGS='${EXTRAFLAGS}'"
31
32 EXTRA_OECONF = '--prefix=${palmtopdir} \
33         --exec-prefix=${palmtopdir} \
34         --includedir=${STAGING_INCDIR} \
35         --with-extra-includes=${STAGING_INCDIR} \
36         --with-extra-libs=${STAGING_LIBDIR} \
37         --with-ssl-version=0.9.7e \
38         --with-ssl-dir=${STAGING_DIR_HOST}${layout_exec_prefix} \
39         --with-qt-includes=${STAGING_DIR_HOST}/qt2/include \
40         --with-qt-libraries=${STAGING_DIR_HOST}/qt2/lib \
41         --enable-fontsubs \
42         --with-konq-tmp-prefix=/tmp/kde-cache \
43 #       --enable-static \
44         --disable-static \
45         --enable-shared \
46         --disable-debug \
47         --with-gui=road \
48         --with-ipv6-lookup=no \
49         --without-xinerama \
50         --disable-scrollbars \
51         --disable-selection \
52         --disable-bookmarks \
53         --with-javascript=static \
54         --enable-debug=yes \
55         --disable-printing \
56         --enable-pcre \
57         --without-arts \
58         --enable-jshostext \
59         --disable-selection \
60         --enable-final \
61         --enable-qt-embedded \
62         --enable-rtti-embedded \
63         --enable-mt \
64         --enable-qt-mt\
65         --enable-fwnewepg=yes \
66         --enable-embedded '
67
68 do_configure_prepend() {
69         cd ${S}
70         if ! test -L admin
71         then
72             ln -s ../kdelibs/admin admin
73         fi
74         make -f Makefile.cvs
75 }
76
77 do_compile_prepend() {
78         perl admin/am_edit
79 }
80
81 FILES_${PN} = "${palmtopdir} ${datadir}"
82