surpport seeking the recorded video
[vuplus_openembedded] / recipes / jikes / jikes-initial.bb
1 SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler"
2
3 DEPENDS = "jikes-native classpath-initial"
4
5 SRC_URI = ""
6
7 S = "${WORKDIR}"
8
9 inherit native
10
11 do_configure() {
12  :
13 }
14
15 do_compile() {
16   echo "#!/bin/sh" > jikes-initial
17   echo "${STAGING_BINDIR_NATIVE}/jikes -bootclasspath ${STAGING_DATADIR_NATIVE}/classpath-initial/glibj.zip \$@" >> jikes-initial
18 }
19
20 do_stage() {
21   install -d ${STAGING_BINDIR}
22   install -m 0755 jikes-initial ${STAGING_BINDIR}
23 }