surpport seeking the recorded video
[vuplus_openembedded] / recipes / jards / jards_1.0.bb
1 DESCRIPTION = "Reference and training tool for students of Japanese"
2 AUTHOR = "Johnny Andersson"
3 HOMEPAGE = "http://gakusei.sf.net"
4 SECTION = "opie/applications"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 RDEPENDS = "virtual-japanese-font qte-mt libpng (>= 1) kpengine"
8 PR = "r8"
9
10 #  stuff that still needs fixing
11 #) is the RDEPENDS line correct and sufficient?
12 #) upon execution there is a message that /usr/lib/libpng12.so.0 does not have version information
13 #) desktop icon missing
14 #) Desktop png file an falscher Stelle, daher kein Icon
15 #) remove .debug dir
16 #) es fehlen: ./opt/QtPalmtop/bin/kpengine, ./opt/QtPalmtop/jardsmob/edict.jardsdic, ./opt/QtPalmtop/jardsmob/kanjidic.jardskdic
17 #) exec muß jardsmob_bin heißen
18 #) Programm geht oft in 100% CPU schleife -> unbenutzbar
19
20 SRC_URI = "${SOURCEFORGE_MIRROR}/gakusei/jards_gakusei.cvs.sourceforge.net__20070212.tar.gz"
21 #SRC_URI = "cvs://anonymous@gakusei.cvs.sourceforge.net/cvsroot/gakusei;method=pserver;module=jards"
22
23 inherit opie
24
25 OE_QMAKE_CXXFLAGS := "${@oe_filter_out('-fno-rtti', '${OE_QMAKE_CXXFLAGS}', d)}"
26
27 S = "${WORKDIR}/${PN}/"
28 export OE_QMAKE_LINK="${CXX}"
29
30 # read opie.bbclass
31 #APPDESKTOP = "${S}"
32 APPTYPE = "binary"
33 APPNAME = "jardsmob"
34
35 FILES_${PN}-dbg += "${D}${palmtopdir}/bin/.debug/"
36
37 PARALLEL_MAKE = ""
38
39 do_install() {
40         install -d ${D}${palmtopdir}/bin/
41         install -d ${D}${palmtopdir}/pics/
42         install -d ${D}${palmtopdir}/${APPNAME}/images
43         install -d ${D}${palmtopdir}/apps/Applications
44         install -m 0644 ${S}dat/images/jardsmob.png ${D}${palmtopdir}/pics/
45         install -m 0644 ${S}dat/images/*.png ${D}${palmtopdir}/${APPNAME}/images/
46         install -m 0755 ${S}jardsmob_bin ${D}${palmtopdir}/bin/
47         install -m 0644 ${WORKDIR}/jards/jards.desktop ${D}${palmtopdir}/apps/Applications/
48
49         # what about the following files: edict.jardsdic kanjidic.jardskdic?
50         for f in markers romkana.utf8 strokedata wordfreq_ck raddat.utf8
51         do
52                 install -m 0644 ${S}dat/$f ${D}${palmtopdir}/${APPNAME}/
53         done
54 }
55