[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / inetutils / inetutils_1.5.bb
1 SECTION = "libs"
2 DEPENDS = "ncurses"
3 LICENSE = "GPL"
4 DESCRIPTION = "The GNU inetutils are a collection of common \
5 networking utilities and servers including ftp, ftpd, rcp, \
6 rexec, rlogin, rlogind, rsh, rshd, syslog, syslogd, talk, \
7 talkd, telnet, telnetd, tftp, tftpd, and uucpd."
8
9 PR = "r1"
10
11 SRC_URI = "${GNU_MIRROR}/inetutils/inetutils-${PV}.tar.gz \
12 "
13
14 inherit autotools
15
16 EXTRA_OECONF = "--with-ncurses-include-dir=${STAGING_INCDIR}"
17
18 do_configure_prepend () {
19         rm -f ${S}/glob/configure*
20 }
21
22 do_install () {
23         autotools_do_install
24         mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${PN}
25         mv ${D}${bindir}/telnet ${D}${bindir}/telnet.${PN}
26         mv ${D}${bindir}/logger ${D}${bindir}/logger.${PN}
27 }
28
29 pkg_postinst_${PN} () {
30         update-alternatives --install ${bindir}/tftp tftp tftp.${PN} 100
31         update-alternatives --install ${bindir}/telnet telnet telnet.${PN} 100
32         update-alternatives --install ${bindir}/logger logger logger.${PN} 100
33 }
34
35 pkg_prerm_${PN} () {
36         update-alternatives --remove tftp tftp.${PN}
37         update-alternatives --remove telnet telnet.${PN}
38         update-alternatives --remove logger logger.${PN}
39 }