surpport seeking the recorded video
[vuplus_openembedded] / recipes / images / jlime-opie.bb
1 PR = "r1"
2 IMAGE_LINGUAS = ""
3
4 DEPENDS = "task-base task-opie"
5
6 extra_stuff = '${@base_conditional("ROOT_FLASH_SIZE", "24", "", "task-opie-extra-games task-opie-extra-apps task-opie-extra-styles konqueror-embedded",d)}'
7
8 IMAGE_INSTALL = "task-base task-opie-base task-opie-base-applets \
9                     task-opie-base-inputmethods task-opie-base-apps \
10                     task-opie-base-settings task-opie-base-decorations \
11                     task-opie-base-styles task-opie-base-pim \
12                     task-opie-extra-settings \
13                     task-opie-bluetooth task-opie-irda \
14                     ${extra_stuff}"
15
16 # merge feed-sources into ipkg.conf for opie-aqpkg as it can't handle feed-sources outside of ipkg.conf.
17 merge_feeds() {
18
19         if ! test -z "${FEED_URIS}"
20         then
21                 # Die gracefully if ipkg-collateral failed
22                 if ! test -e "${IMAGE_ROOTFS}/etc/ipkg.conf"
23                 then
24                         echo "[${IMAGE_ROOTFS}/etc/ipkg.conf] is missing!"
25                         exit 1
26                 fi
27
28                 # comment out existing feed-sources inserted by ipkg-collateral
29                 cat ${IMAGE_ROOTFS}/etc/ipkg.conf | sed "s/^src\ /#src\ /" > ${IMAGE_ROOTFS}/etc/ipkg.conf_
30                 rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
31
32                 # extract, then delete destinations
33                 cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
34                 cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep -v "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf_
35                 rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
36
37
38                 for line in ${FEED_URIS}
39                 do
40                         # strip leading and trailing spaces/tabs, then split into name and uri
41                         line_clean="`echo "$line"|sed 's/^[ \t]*//;s/[ \t]*$//'`"
42                         feed_name="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\1/p'`"
43                         feed_uri="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\2/p'`"
44
45                         # insert new feed-sources
46                         echo "src/gz $feed_name $feed_uri" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
47                 done
48
49                 # remove temporary files and rebuild ipkg.conf
50                 echo "" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
51                 cat ${IMAGE_ROOTFS}/etc/ipkg.conf.dest >> ${IMAGE_ROOTFS}/etc/ipkg.conf
52                 rm ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
53
54                 # remove -feed.conf files which are no longer needed
55                 cd ${IMAGE_ROOTFS}/etc/ipkg/ && rm -- *-feed.conf
56         fi
57 }
58
59 # merge feed-sources into ipkg.conf and create /etc/timestamp from build date
60 IMAGE_PREPROCESS_COMMAND = "merge_feeds; create_etc_timestamp"
61
62 inherit image