surpport seeking the recorded video
[vuplus_openembedded] / recipes / hotplug-ng / hotplug-ng.bb
1 DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
2 package with very tiny, compiled executable programs, instead of the \
3 existing bash scripts."
4 LICENSE = "GPL"
5 RPROVIDES_${PN} = "hotplug"
6 RCONFLICTS_${PN} = "hotplug"
7 RREPLACES_${PN} = "hotplug"
8
9 SRC_URI = "svn://svn.schwerkraft.elitedvb.net/svnroot;module=hotplug-ng"
10 SRCDATE = "20100119"
11 PV = "002+svn${SRCDATE}"
12
13 S = "${WORKDIR}/hotplug-ng/trunk"
14
15 LD = "${CC}"
16 export HOSTCC = "${BUILD_CC}"
17 CFLAGS = " -I${S}/libsysfs/sysfs"
18 # Stripping should be done when _packaging_, not building
19 EXTRA_OEMAKE += "'STRIP=/bin/true'"
20
21 export etcdir = "${sysconfdir}"
22 export sbindir = "${base_sbindir}"
23 export bindir = "${base_bindir}"
24
25 do_install () {
26         oe_runmake 'DESTDIR=${D}' install
27 }