surpport seeking the recorded video
[vuplus_openembedded] / recipes / hfsplusutils / hfsplusutils_1.0.4-4.bb
1 DESCRIPTION = "HFS plus file system utilities"
2 SECTION = "base"
3 LICENSE = "GPL"
4 PR = "r1"
5
6 S="${WORKDIR}/${P}"
7
8 inherit kernel-arch autotools pkgconfig
9
10 DEPENDS = " rpm2cpio-native"
11
12 SRC_URI = "http://penguinppc.org/historical/hfsplus/hfsplusutils-1.0.4-4.src.rpm \
13            file://hfsplusutils-1.0.4-errno.patch;patch=1 \
14            file://hfsplusutils-1.0.4-gcc4.patch;patch=1 \
15            file://hfsplusutils-1.0.4-glob.patch;patch=1 \
16            file://hfsplusutils-1.0.4-string.patch;patch=1 \
17                 "
18
19 do_unpack() {
20         if ! test -f hfsplus.tz2 ; then
21                 rpm2cpio.pl ${DL_DIR}/${P}.src.rpm | cpio -i --make-directories
22                 bunzip2 hfsplus.tz2
23                 tar -xf hfsplus.tz2.out
24                 mv hfsplus ${P}
25         fi
26 }