surpport seeking the recorded video
[vuplus_openembedded] / recipes / hdparm / hdparm_6.9.bb
1 DESCRIPTION = "hdparm is a Linux shell utility for viewing \
2 and manipulating various IDE drive and driver parameters."
3 SECTION = "console/utils"
4 PRIORITY = "optional"
5 LICENSE = "BSD"
6
7 PR = "r1"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz \
10            file://bswap.patch;patch=1 \
11            file://uclibc.patch;patch=1"
12
13 do_install () {
14         install -d ${D}/${base_sbindir} ${D}/${mandir}/man8
15         oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
16         mv ${D}${base_sbindir}/hdparm ${D}${base_sbindir}/hdparm.${PN}
17 }
18
19 pkg_postinst_${PN} () {
20         update-alternatives --install ${base_sbindir}/hdparm hdparm hdparm.${PN} 100
21 }
22
23 pkg_prerm_${PN} () {
24         update-alternatives --remove hdparm hdparm.${PN}
25 }