surpport seeking the recorded video
[vuplus_openembedded] / recipes / handsfree / handsfree_0.1.bb
1 DESCRIPTION = "Handsfree and Handset Bluetooth tool"
2 HOMEPAGE = "http://www.soft.uni-linz.ac.at/_wiki/tiki-index.php?page=ProjectBluezHandsfree"
3 SECTION = "network/misc"
4 PRIORITY = "optional"
5 LICENSE = "GPLv2"
6 DEPENDS= "bluez-libs alsa-lib"
7 PR = "r0"
8
9
10 SRC_URI = "\
11    http://www.soft.uni-linz.ac.at/~vogl/bluez/handsfree-040326.tar.gz \
12   file://Makefile.patch;patch=1 \
13 "
14 S = "${WORKDIR}/handsfree"
15
16 # Alsa devices
17 # Example: "plughw:0,0"
18 ALSA_PLAY = "default"
19 ALSA_REC = "default"
20
21 CFLAGS =+ "-DOSS=0 "
22 LDFLAGS =+ "-lbluetooth -lasound "
23
24 do_compile() {
25         oe_runmake all
26 }
27
28 do_install() {
29         install -d ${D}${bindir}
30         install -m 0755 handsfree ${D}${bindir}
31         install -m 0755 headset ${D}${bindir}
32 }