surpport seeking the recorded video
[vuplus_openembedded] / recipes / hal / hal-cups-utils_0.6.19.bb
1 DESCRIPTION = "Utilities to detect and configure printers automatically"
2 HOMEPAGE = "https://fedorahosted.org/hal-cups-utils/"
3 SECTION = "console/utils"
4 LICENSE = "GPLv2 CUPS"
5 DEPENDS = "hal dbus cups"
6 RDEPENDS_${PN} += "python-dbus python-pycups python-cupshelpers python-subprocess python-syslog usbutils"
7
8 SRC_URI = "https://fedorahosted.org/releases/h/a/hal-cups-utils/hal-cups-utils-${PV}.tar.gz"
9 S = "${WORKDIR}/${PN}-${PV}"
10
11 inherit autotools
12
13 PACKAGES += "cups-backend-hal"
14
15 FILES_${PN} += "${libdir}/hal/* ${datadir}/hal/*"
16 FILES_${PN}-dbg += "${libdir}/hal/.debug ${libdir}/cups/backend/.debug"
17 FILES_cups-backend-hal += "${libdir}/cups/backend/*"
18
19 EXTRA_OECONF = "--libexecdir=${libdir}/hal/scripts"
20
21 do_configure_prepend() {
22         sed -i -e s:{includedir}/cups:{STAGING_INCDIR}/cups:g configure.in
23 }
24
25 do_configure_append() {
26         sed -i 's,^#!/bin/env python,#!/usr/bin/python,' systemv/hal_lpadmin
27 }