modify recipes/gstreamer.
[vuplus_openembedded] / recipes / gstreamer / gst-plugins-base_0.10.29.bb
1 require gst-plugins.inc
2
3 SRC_URI_append_opendreambox = " file://samihack.patch;patch=1 \
4 file://playbin2-Set-subtitle-encoding-on-the-decodebins-a.patch;patch=1 \
5 file://playbin2-If-a-text-sink-is-provided-let-subtitle-p.patch;patch=1 "
6
7 SRC_URI_append_vuplus = " file://samihack.patch;patch=1 \
8 file://playbin2-Set-subtitle-encoding-on-the-decodebins-a.patch;patch=1 \
9 file://playbin2-If-a-text-sink-is-provided-let-subtitle-p.patch;patch=1 \
10 file://jsseek_have_x.patch;patch=1 "
11
12 PR = "${INC_PR}.0"
13
14 PROVIDES += "gst-plugins"
15
16 # gst-plugins-base only builds the alsa plugin
17 # if alsa has been built and is present.  You will
18 # not get an error if this is not present, just 
19 # a missing alsa plugin
20 #DEPENDS += "${@base_contains('DISTRO', 'opendreambox', 'alsa-lib', 'cdparanoia pango libtheora alsa-lib libsm virtual/libx11 freetype gnome-vfs libxv', d)}"
21 DEPENDS += "${@base_contains('DISTRO', 'vuplus', 'alsa-lib', 'cdparanoia pango libtheora alsa-lib libsm virtual/libx11 freetype gnome-vfs libxv', d)}"
22 EXTRA_OECONF_opendreambox += "--disable-theora --disable-pango --with-audioresample-format=int"
23 EXTRA_OECONF_vuplus += "--disable-theora --disable-pango --with-audioresample-format=int"
24