Merge branch 'opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / gstreamer / gst-plugins-base_0.10.29.bb
1 require gst-plugins.inc
2
3 SRC_URI_append_opendreambox = " file://samihack.patch;patch=1 \
4 file://playbin2-Set-subtitle-encoding-on-the-decodebins-a.patch;patch=1 \
5 file://playbin2-If-a-text-sink-is-provided-let-subtitle-p.patch;patch=1 \
6 file://playbin2-capsless-textsink.patch;patch=1 "
7
8 SRC_URI_append_vuplus = " file://samihack.patch;patch=1 \
9 file://playbin2-Set-subtitle-encoding-on-the-decodebins-a.patch;patch=1 \
10 file://playbin2-If-a-text-sink-is-provided-let-subtitle-p.patch;patch=1 \
11 file://playbin2-capsless-textsink.patch;patch=1 "
12
13 PR = "${INC_PR}.0"
14
15 PROVIDES += "gst-plugins"
16
17 # gst-plugins-base only builds the alsa plugin
18 # if alsa has been built and is present.  You will
19 # not get an error if this is not present, just 
20 # a missing alsa plugin
21 #DEPENDS += "${@base_contains('DISTRO', 'opendreambox', 'alsa-lib', 'cdparanoia pango libtheora alsa-lib libsm virtual/libx11 freetype gnome-vfs libxv', d)}"
22 DEPENDS += "${@base_contains('DISTRO', 'vuplus', 'alsa-lib', 'cdparanoia pango libtheora alsa-lib libsm virtual/libx11 freetype gnome-vfs libxv', d)}"
23 EXTRA_OECONF_opendreambox += "--disable-theora --disable-pango --with-audioresample-format=int"
24 EXTRA_OECONF_vuplus += "--disable-theora --disable-pango --with-audioresample-format=int"
25