surpport seeking the recorded video
[vuplus_openembedded] / recipes / gs / gs_8.64.bb
1 DESCRIPTION = "An interpreter of the Postscript language"
2 LICENSE = "GPL"
3 SECTION = "console/utils"
4 HOMEPAGE = "http://www.gnu.org/software/ghostscript/ghostscript.html"
5 DEPENDS = "jpeg zlib fontconfig cups"
6 PR = "r2"
7
8 SRC_URI = "${DEBIAN_MIRROR}/main/g/ghostscript/ghostscript_${PV}~dfsg.orig.tar.gz \
9            file://0001_svn_snapshot.patch;patch=1 \
10            file://0002_svn_snapshot_jbig2dec.patch;patch=1 \
11            file://1001_install_cjk_examples.patch;patch=1 \
12            file://1002_ps2pdf_man_fix.patch;patch=1 \
13            file://1003_fix_autoconf_create_from_infiles.patch;patch=1 \
14            file://1004_CVE-2009-0792_CVE-2009-0584_CVE-2009-0583.patch;patch=1 \
15            file://1006_system-jasper.patch;patch=1 \
16            file://1007_fix_pphs_script_not_lib.patch;patch=1 \
17            file://2001_docdir_fix_for_debian.patch;patch=1 \
18            file://2002_gs_man_fix_debian.patch;patch=1 \
19            "
20
21 S = "${WORKDIR}/ghostscript-${PV}~dfsg"
22
23 inherit autotools
24
25 EXTRA_OECONF = "--without-x --with-jasper --with-zlib=${STAGING_DIR_HOST}${layout_prefix}"
26
27 PACKAGES += "cups-gs"
28
29 do_configure() {
30         # hack script to allow for cross compiling
31         sed 's,&& ./configure$,& --host=\$host --build=\$build --target=\$target,g' -i configure
32  
33         gnu-configize
34         oe_runconf
35 }
36
37 do_stage () {
38         install -d ${STAGING_INCDIR}/ghostscript
39         install -m 755 ${S}/psi/*.h ${STAGING_INCDIR}/ghostscript/
40         oe_libinstall -so -C sobin libgs ${STAGING_LIBDIR}
41 }
42
43 do_compile_append () {
44         oe_runmake so
45 }
46
47 do_install_append () {
48         oe_runmake 'DESTDIR=${D}' soinstall
49 }
50
51 FILES_${PN} += "${datadir}/ghostscript"
52 FILES_cups-gs = "${libdir}/cups/filter/* ${datadir}/cups ${sysconfdir}/cups"
53
54 RDEPENDS_cups-gs += "gs"