surpport seeking the recorded video
[vuplus_openembedded] / recipes / gpe-mini-browser / gpe-mini-browser_svn.bb
1 DEPENDS = "sqlite gettext gtk+ glib-2.0 osb-nrcit libgpewidget"
2 RRECOMMENDS = "gdk-pixbuf-loader-gif gdk-pixbuf-loader-png gdk-pixbuf-loader-jpeg"
3 PV = "0.20+svn${SRCDATE}"
4 PR = "r0"
5
6 inherit autotools
7
8 SRC_URI = "${GPE_EXTRA_SVN}"
9
10 S = "${WORKDIR}/gpe-mini-browser"
11
12 do_install() {
13                 install -d ${D}/usr/share/applications
14                 install -m 0644 ${S}/gpe-mini-browser.desktop ${D}/usr/share/applications/gpe-mini-browser.desktop
15                 install -d ${D}/usr/share/pixmaps
16                 install -m 0644 ${S}/gpe-mini-browser.png ${D}/usr/share/pixmaps/gpe-mini-browser.png
17                 autotools_do_install
18 }
19
20 pkg_postinst_${PN}-doc () {
21         #!/bin/sh
22         if [ "x$D" != "x" ]; then
23         if [ -e /etc/gpe/gpe-help.conf ]; then
24                 echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
25         else
26                  echo [Help] >> /etc/gpe/gpe-help.conf
27                  echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
28         fi
29         if [ -x /usr/bin/gpe-helpindex ]; then
30                 echo generating help-index
31                 gpe-helpindex
32         else
33                 echo not generating index for gpe-mini-browser
34         fi
35         fi
36 }
37 pkg_postrm_${PN}-doc () {
38         #!/bin/sh
39         if [ -e /etc/gpe/gpe-help.conf ]; then
40                 sed '/^\<gpe-mini-browser\>/d' /etc/gpe/gpe-help.conf > /tmp/gpe-help.conf
41                 mv /tmp/gpe-help.conf /etc/gpe/gpe-help.conf
42         fi
43         if [ -x /usr/bin/gpe-helpindex ]; then
44                 echo generating help-index
45                 gpe-helpindex
46         else
47                 echo not generating index for gpe-mini-browser
48         fi
49 }
50
51 require gpe-mini-browser.inc
52
53 #DEFAULT_PREFERENCE = "-1"