surpport seeking the recorded video
[vuplus_openembedded] / recipes / gpe-mini-browser / gpe-mini-browser_0.19.bb
1 require gpe-mini-browser.inc
2
3 SRC_URI = "http://gpe.linuxtogo.org/download/source/gpe-mini-browser-${PV}.tar.gz"
4 DEPENDS = "osb-nrcit sqlite libgpewidget"
5 RRECOMMENDS = "gdk-pixbuf-loader-gif gdk-pixbuf-loader-png gdk-pixbuf-loader-jpeg"
6
7 PR = "r1"
8
9 S = "${WORKDIR}/gpe-mini-browser-${PV}"
10
11 inherit autotools
12
13 do_install() {
14                 install -d ${D}/usr/share/applications
15                 install -m 0644 ${S}/gpe-mini-browser.desktop ${D}/usr/share/applications/gpe-mini-browser.desktop
16                 install -d ${D}/usr/share/pixmaps
17                 install -m 0644 ${S}/gpe-mini-browser.png ${D}/usr/share/pixmaps/gpe-mini-browser.png
18                 autotools_do_install
19 }
20
21 pkg_postinst_${PN}-doc () {
22         #!/bin/sh
23         if [ "x$D" != "x" ]; then
24         if [ -e /etc/gpe/gpe-help.conf ]; then
25                 echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
26         else
27                  echo [Help] >> /etc/gpe/gpe-help.conf
28                  echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
29         fi
30         if [ -x /usr/bin/gpe-helpindex ]; then
31                 echo generating help-index
32                 gpe-helpindex
33         else
34                 echo not generating index for gpe-mini-browser
35         fi
36         fi
37 }
38
39 pkg_postrm_${PN}-doc () {
40         #!/bin/sh
41         if [ -e /etc/gpe/gpe-help.conf ]; then
42                 sed '/^\<gpe-mini-browser\>/d' /etc/gpe/gpe-help.conf > /tmp/gpe-help.conf
43                 mv /tmp/gpe-help.conf /etc/gpe/gpe-help.conf
44         fi
45         if [ -x /usr/bin/gpe-helpindex ]; then
46                 echo generating help-index
47                 gpe-helpindex
48         else
49                 echo not generating index for gpe-mini-browser
50         fi
51 }
52