surpport seeking the recorded video
[vuplus_openembedded] / recipes / gpe-mini-browser / gpe-mini-browser-hildon_0.16.bb
1 require gpe-mini-browser.inc
2
3 PR = "r0"
4
5 SRC_URI      = "${GPE_MIRROR}/gpe-mini-browser-${PV}.tar.gz"
6 DESCRIPTION  = "A lightweight webbrowser for the GPE platform (Hildon UI)"
7 DEPENDS      = "osb-nrcit libosso hildon-lgpl hildon-fm libgpewidget"
8 EXTRA_OECONF = "--enable-hildon"
9
10 S = "${WORKDIR}/gpe-mini-browser-${PV}"
11
12 inherit autotools
13
14 do_install() {
15                 install -d ${D}/usr/share/applications/hildon
16                 install -m 0644 ${S}/hildon/gpe-mini-browser.desktop ${D}/usr/share/applications/hildon/gpe-mini-browser.desktop
17                 install -d ${D}/usr/share/pixmaps
18                 install -m 0644 ${S}/gpe-mini-browser.png ${D}/usr/share/pixmaps/gpe-mini-browser.png
19                 autotools_do_install
20 }
21
22 pkg_postinst_${PN}-doc () {
23         #!/bin/sh
24         if [ "x$D" != "x" ]; then
25         if [ -e /etc/gpe/gpe-help.conf ]; then
26                 echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
27         else
28                  echo [Help] >> /etc/gpe/gpe-help.conf
29                  echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
30         fi
31         if [ -x /usr/bin/gpe-helpindex ]; then
32                 echo generating help-index
33                 gpe-helpindex
34         else
35                 echo not generating index for gpe-mini-browser
36         fi
37         fi
38 }
39
40 pkg_postrm_${PN}-doc () {
41         #!/bin/sh
42         if [ -e /etc/gpe/gpe-help.conf ]; then
43                 sed '/^\<gpe-mini-browser\>/d' /etc/gpe/gpe-help.conf > /tmp/gpe-help.conf
44                 mv /tmp/gpe-help.conf /etc/gpe/gpe-help.conf
45         fi
46         if [ -x /usr/bin/gpe-helpindex ]; then
47                 echo generating help-index
48                 gpe-helpindex
49         else
50                 echo not generating index for gpe-mini-browser
51         fi
52 }