surpport seeking the recorded video
[vuplus_openembedded] / recipes / gnuchess / fltk-chess_0.5.bb
1 DESCRIPTION = "fltk-chess is a frontend for the Gnuchess chess playing engine."
2 AUTHOR = "Andreas Holzer <a.holzer@cheese.at>"
3 SECTION = "x11/games"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "fltk"
7 RDEPENDS = "gnuchess"
8
9
10 SRC_URI = "http://members.cheese.at/woody/fltk-chess/fltk-chess-${PV}.tgz \
11            file://fix_cast_error_and_gnuchess_exec.patch;patch=1 \
12            file://fltk-chess.desktop"
13 S = "${WORKDIR}/fltk-chess/"
14
15
16 do_compile() {
17         `fltk-config --cxx --cxxflags --ldflags --use-images` -o fltk-chess \
18          fltk-chess.cxx
19 }
20
21 do_install() {
22         install -d ${D}${bindir}
23         install -d ${D}${datadir}/pixmaps/fltk-chess/
24         install -d ${D}${datadir}/applications/
25         install -m 0755 ${S}/fltk-chess ${D}${bindir}
26         install -m 0644 ${S}/bitmaps/*.pnx ${D}${datadir}/pixmaps/fltk-chess/
27         install -m 0644 ${S}/bitmaps/{user,computer}.png \
28                 ${D}${datadir}/pixmaps/fltk-chess/
29         install -m 0644 ${S}/bitmaps/fltk-chess.png  ${D}${datadir}/pixmaps/
30         install -m 0644 ${WORKDIR}/fltk-chess.desktop  ${D}${datadir}/applications/
31 }
32
33