surpport seeking the recorded video
[vuplus_openembedded] / recipes / gnome / libbonoboui_2.24.1.bb
1 #DEFAULT_PREFERENCE = "-1"
2
3 LICENSE = "GPL"
4 SECTION = "x11/gnome/libs"
5 PR = "r0"
6
7 inherit gnome pkgconfig
8
9 FILES_${PN} += "${libdir}/libglade/2.0/*.so"
10 FILES_${PN}-dev += "${libdir}/libglade/2.0/* ${datadir}/gnome-2.0/ui \
11         ${libdir}/bonobo-2.0/samples"
12 FILES_${PN}-dbg += "${libdir}/bonobo-2.0/samples/.debug \
13         ${libdir}/libglade/2.0/.debug"
14
15 DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
16
17 EXTRA_OECONF = "--disable-gtk-doc"
18
19 HEADERS = " \
20 bonobo/bonobo-zoomable.h \
21 bonobo/bonobo-ui-component.h \
22 bonobo/bonobo-dock-layout.h \
23 bonobo/bonobo-ui-type-builtins.h \
24 bonobo/bonobo-canvas-component.h \
25 bonobo/bonobo-widget.h \
26 bonobo/bonobo-ui-engine.h \
27 bonobo/bonobo-window.h \
28 bonobo/bonobo-ui-toolbar.h \
29 bonobo/bonobo-dock-band.h \
30 bonobo/bonobo-ui-toolbar-item.h \
31 bonobo/bonobo-control.h \
32 bonobo/bonobo-dock-item.h \
33 bonobo/bonobo-ui-config-widget.h \
34 bonobo/bonobo-zoomable-frame.h \
35 bonobo/bonobo-control-frame.h \
36 bonobo/bonobo-dock.h \
37 bonobo/bonobo-ui-main.h \
38 bonobo/bonobo-canvas-item.h \
39 bonobo/bonobo-ui-node.h \
40 bonobo/bonobo-socket.h \
41 bonobo/bonobo-selector.h \
42 bonobo/bonobo-ui-sync.h \
43 bonobo/bonobo-ui-util.h \
44 bonobo/bonobo-plug.h \
45 bonobo/bonobo-ui-toolbar-button-item.h \
46 bonobo/bonobo-ui-toolbar-toggle-button-item.h \
47 bonobo/bonobo-ui-container.h \
48 bonobo/bonobo-file-selector-util.h \
49 bonobo/bonobo-property-control.h \
50 bonobo/bonobo-selector-widget.h \
51 libbonoboui.h \
52 bonobo.h \
53 "
54
55 do_stage() {
56         install -d ${STAGING_INCDIR}/libbonoboui-2.0/bonobo
57         for i in ${HEADERS}; do
58                 install -m 0644 $i ${STAGING_INCDIR}/libbonoboui-2.0/$i
59         done
60         oe_libinstall -C bonobo -a -so libbonoboui-2 ${STAGING_LIBDIR}
61 }