surpport seeking the recorded video
[vuplus_openembedded] / recipes / gnome / libbonoboui_2.10.0.bb
1 LICENSE = "GPL"
2 SECTION = "x11/gnome/libs"
3 PR = "r2"
4
5 inherit gnome pkgconfig
6
7 FILES_${PN} += "${libdir}/libglade/2.0/*.so"
8 FILES_${PN}-dev += "${libdir}/libglade/2.0/* ${datadir}/gnome-2.0/ui \
9         ${libdir}/bonobo-2.0/samples"
10 FILES_${PN}-dbg += "${libdir}/libglade/2.0/.debug/*.so"
11
12 DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
13
14 EXTRA_OECONF = "--disable-gtk-doc"
15
16 HEADERS = " \
17 bonobo/bonobo-zoomable.h \
18 bonobo/bonobo-ui-component.h \
19 bonobo/bonobo-dock-layout.h \
20 bonobo/bonobo-ui-type-builtins.h \
21 bonobo/bonobo-canvas-component.h \
22 bonobo/bonobo-widget.h \
23 bonobo/bonobo-ui-engine.h \
24 bonobo/bonobo-window.h \
25 bonobo/bonobo-ui-toolbar.h \
26 bonobo/bonobo-dock-band.h \
27 bonobo/bonobo-ui-toolbar-item.h \
28 bonobo/bonobo-control.h \
29 bonobo/bonobo-dock-item.h \
30 bonobo/bonobo-ui-config-widget.h \
31 bonobo/bonobo-zoomable-frame.h \
32 bonobo/bonobo-control-frame.h \
33 bonobo/bonobo-dock.h \
34 bonobo/bonobo-ui-main.h \
35 bonobo/bonobo-canvas-item.h \
36 bonobo/bonobo-ui-node.h \
37 bonobo/bonobo-socket.h \
38 bonobo/bonobo-selector.h \
39 bonobo/bonobo-ui-sync.h \
40 bonobo/bonobo-ui-util.h \
41 bonobo/bonobo-plug.h \
42 bonobo/bonobo-ui-toolbar-button-item.h \
43 bonobo/bonobo-ui-toolbar-toggle-button-item.h \
44 bonobo/bonobo-ui-container.h \
45 bonobo/bonobo-file-selector-util.h \
46 bonobo/bonobo-property-control.h \
47 bonobo/bonobo-selector-widget.h \
48 libbonoboui.h \
49 bonobo.h \
50 "
51
52 do_stage() {
53         install -d ${STAGING_INCDIR}/libbonoboui-2.0/bonobo
54         for i in ${HEADERS}; do
55                 install -m 0644 $i ${STAGING_INCDIR}/libbonoboui-2.0/$i
56         done
57         oe_libinstall -C bonobo -a -so libbonoboui-2 ${STAGING_LIBDIR}
58 }