surpport seeking the recorded video
[vuplus_openembedded] / recipes / gnome / gnumeric_1.9.14.bb
1 LICENSE = "GPL"
2 SECTION = "x11/utils"
3 DEPENDS = "gdk-pixbuf-csource-native libgsf gtk+ libxml2 goffice libglade libart-lgpl intltool-native libgnomecanvas libgnomeprint libgnomeprintui libbonoboui orbit2-native"
4 DESCRIPTION = "Gnumeric spreadsheet for GNOME"
5
6 PARALLEL_MAKE = ""
7
8 inherit gnome flow-lossage
9
10 SRC_URI += " file://nodolt.patch;patch=1 "
11
12 EXTRA_OECONF=" --without-perl "
13
14 PACKAGES_DYNAMIC += "gnumeric-plugin-*"
15
16 FILES_${PN}-dbg += "${libdir}/gnumeric/${PV}/plugins/*/.debug"
17 FILES_${PN} += "${libdir}/libspreadsheet-${PV}.so "
18
19 do_configure_prepend() {
20         sed -i -e s:doc\ tools:tools: ${S}/Makefile.am
21 }
22
23 # We need native orbit-idl with target idl files. No way to say it in a clean way:
24 do_configure_append () {
25         find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
26 }
27
28 python populate_packages_prepend () {
29         gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
30
31         do_split_packages(d, gnumeric_libdir, '(.*)', 'gnumeric-plugin-%s', 'Gnumeric plugin for %s', allow_dirs=True)
32 }