gecko-mediaplayer: make ai-flash.js work with midori as well
[vuplus_openembedded] / recipes / gnome-mplayer / gecko-mediaplayer_0.9.8.bb
1 DESCRIPTION = "Gecko plugin for gnome-mplayer"
2 HOMEPAGE = "http://dekorte.homeip.net/download/gecko-mediaplayer/"
3 LICENSE = "GPL"
4 DEPENDS = "firefox gtk+ gconf dbus-glib"
5 RDEPENDS = "firefox gnome-mplayer"
6
7 PR = "r7"
8
9 inherit autotools
10
11 SRC_URI = "http://gecko-mediaplayer.googlecode.com/files/${P}.tar.gz \
12            file://gecko-mplayer-svn.diff;patch=1;pnum=0 \
13            file://extensions \
14 "
15
16 do_install_append() {
17         cp -dpR ${WORKDIR}/extens* ${D}${libdir}/mozilla/
18 }
19
20 PACKAGES =+ "${PN}-firefox-hack"
21 RDEPENDS_${PN}-firefox-hack = "${PN}"
22 FILES_${PN}-firefox-hack = "${libdir}/mozilla/extensions"
23
24 FILES_${PN} += "${sysconfdir}/* \
25                 ${libdir}/mozilla/*"
26 FILES_${PN}-dbg += "${libdir}/mozilla*/plugins/.debug/*"
27
28 pkg_postinst_${PN}-firefox-hack() {
29 for firefoxdir in $D${libdir}/firefox-* ; do
30         if [ -e $firefoxdir/extensions/ ] ; then 
31                 ln -sf ${libdir}/mozilla/extensions/flash@alwaysinnovating.com $firefoxdir/extensions/
32         fi
33 done
34 }
35