surpport seeking the recorded video
[vuplus_openembedded] / recipes / glibc / glibc_2.3.3+cvs20050420.bb
1 require glibc.inc
2
3 DEFAULT_PREFERENCE_i586 = "0"
4
5 DEFAULT_PREFERENCE_sh3 = "-99"
6
7 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs"
8 PR = "${INC_PR}.0"
9
10 GLIBC_ADDONS ?= "linuxthreads"
11
12 DEFAULT_PREFERENCE = "-1"
13
14 #          file://noinfo.patch;patch=1
15 #          file://ldconfig.patch;patch=1;pnum=0
16 SRC_URI = "cvs://anoncvs@sources.redhat.com/cvs/glibc;module=libc;date=${@bb.data.getVar('PV', d, 1)[9:]} \
17            file://arm-ioperm.patch;patch=1;pnum=0 \
18            file://fhs-linux-paths.patch;patch=1 \
19            file://arm-no-hwcap.patch;patch=1;pnum=0 \
20            file://arm-memcpy.patch;patch=1;pnum=0 \
21            file://arm-longlong.patch;patch=1;pnum=0 \
22            file://arm-machine-gmon.patch;patch=1;pnum=0 \
23            file://trampoline.patch;patch=1;pnum=0 \
24            file://eabi-patch-1;patch=1 \
25            file://eabi-patch-2;patch=1 \
26            file://eabi-patch-3;patch=1 \
27            file://5090_all_stubs-rule-fix.patch;patch=1 \
28            file://etc/ld.so.conf \
29            file://generate-supported.mk"
30
31 # seems to fail on tls platforms
32 SRC_URI_append_arm = " file://dyn-ldconfig-20041128.patch;patch=1"
33
34 SRC_URI_append_openmn = " file://ldsocache-varrun.patch;patch=1"
35
36 S = "${WORKDIR}/libc"
37 B = "${WORKDIR}/build-${TARGET_SYS}"
38
39 RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
40 RPROVIDES_${PN}-dev += "libc-dev virtual-libc-dev"
41
42 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
43                 --without-cvs --disable-profile --disable-debug --without-gd \
44                 --enable-clocale=gnu \
45                 --enable-add-ons=${GLIBC_ADDONS} \
46                 --with-headers=${STAGING_INCDIR} \
47                 --without-selinux \
48                 ${GLIBC_EXTRA_OECONF}"
49
50 do_configure () {
51 # override this function to avoid the autoconf/automake/aclocal/autoheader
52 # calls for now
53 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
54 # version check and doesn't really help with anything
55         if [ -z "`which rpcgen`" ]; then
56                 echo "rpcgen not found.  Install glibc-devel."
57                 exit 1
58         fi
59         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
60         CPPFLAGS="" oe_runconf
61 }
62
63 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
64           yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
65           rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
66
67 do_compile () {
68         # this really is arm specific
69         touch ${S}/sysdeps/arm/framestate.c
70         # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
71         unset LDFLAGS
72         base_do_compile
73         (
74                 cd ${S}/sunrpc/rpcsvc
75                 for r in ${rpcsvc}; do
76                         h=`echo $r|sed -e's,\.x$,.h,'`
77                         rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
78                 done
79         )
80 }
81
82 require glibc-stage.inc
83
84 require glibc-package.inc