surpport seeking the recorded video
[vuplus_openembedded] / recipes / frozen-bubble / frozen-bubble_2.2.0.bb
1 DESCRIPTION="A Puzzle Bubble clone written in perl (now with network support)"
2 LICENSE = "GPL"
3 SECTION = "games"
4 DEPENDS = "sdlpango libsdl-mixer perl"
5 RDEPENDS_${PN} = "${PN}-data perl sdl-perl \
6                   perl-module-strict perl-module-vars \
7                   perl-module-getopt-long perl-module-exporter-heavy \
8                   perl-module-data-dumper \
9                   perl-module-bytes liblocale-gettext-perl \
10                   perl-module-dynaloader perl-module-posix \
11                   perl-module-autoloader perl-module-math-trig \
12                   perl-module-io-file perl-module-io \
13                   perl-module-file-spec-unix perl-module-time-hires \
14                   perl-module-io-socket perl-module-io-select \
15                   perl-module-file-glob \
16                  "
17
18 PR = "r1"
19
20 inherit cpan-base
21
22 PERL_VERSION = ${@get_perl_version(d)}
23
24 SRC_URI = "http://www.frozen-bubble.org/data/frozen-bubble-${PV}.tar.bz2 \
25            file://Makefile.PL.patch;patch=1 \
26            file://Makefile.patch;patch=1 \
27            file://Makefile_top.patch;patch=1 \
28            file://localespath-fix.patch;patch=1 \
29           "
30
31 #permit the installation of the locales in ${datadir}/locales otherwise they are installed in /usr/local/share/locales
32
33 # The Makefile needs to be patched to look in STAGING_LIBDIR/perl/... - It's looking in i686-linux/lib at the moment, regardless of arch
34 BROKEN = "1"
35
36 do_compile() {
37         oe_runmake OPTIMIZE="${CFLAGS}" PREFIX="${prefix}" INSTALLSITELIB="${D}/${libdir}/perl/${PERL_VERSION}/" LOCALEDIR="${datadir}/locale"
38 }
39
40 do_install() {
41         oe_runmake PREFIX="${prefix}" DESTDIR="${D}" DATADIR="${datadir}" LOCALEDIR="${datadir}/locale" install 
42 }
43
44 PACKAGES += "${PN}-editor ${PN}-data ${PN}-server"
45
46
47 DESCRIPTION_${PN}-editor = "Map Editor for Frozen Bubble"
48 DESCRIPTION_${PN}-data = "Mandatory data package for Frozen Bubble"
49 DESCRIPTION_${PN}-server = "Server for Frozen Bubble"
50
51 FILES_${PN} = "\
52   ${bindir}/frozen-bubble \
53   ${libdir}/perl/${PERL_VERSION}/auto/fb_c_stuff/fb_c_stuff.* \
54   ${libdir}/perl/${PERL_VERSION}/fb* \
55   ${libdir}/perl/${PERL_VERSION}/perllocal.pod \
56   ${libdir}/perl/${PERL_VERSION}/FBLE.pm \
57 "
58
59 FILES_${PN}-dbg += " \
60  ${libdir}/perl/${PERL_VERSION}/auto/fb_c_stuff/.debug \
61  ${libdir}/${PN}/.debug \
62 "
63
64 FILES_${PN}-editor = "\
65   ${bindir}/frozen-bubble-editor \
66 "
67
68 FILES_${PN}-data = "\
69   ${datadir}/frozen-bubble \
70 "
71
72 FILES_${PN}-server = " \
73  ${libdir}/${PN}/fb-server \
74 "