surpport seeking the recorded video
[vuplus_openembedded] / recipes / ffmpeg / omapfbplay_git.bb
1 DESCRIPTION = "Simple ffmpeg-based player that uses the omapfb overlays"
2 DEPENDS = "bzip2 lame ffmpeg virtual/kernel"
3 LICENSE = "MIT"
4
5 PR = "r18"
6
7 PV = "0.0+${PR}+gitr${SRCREV}"
8
9 SRCREV = "26df4208b57ccb0f0ca101ae4ddb92c956a0ecc0"
10 SRC_URI = "git://git.mansr.com/${PN};protocol=git \
11            file://fbplay-static.diff;patch=1 "
12
13 S = "${WORKDIR}/git"
14
15 # We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that
16 STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"
17
18 CFLAGS += " -I. -I${STAGING_KERNEL_DIR}/include "
19
20 do_compile() {
21         cp ${STAGING_KERNEL_DIR}/arch/arm/plat-omap/include/mach/omapfb.h ${S} || true
22         cp ${STAGING_KERNEL_DIR}/include/asm-arm/arch-omap/omapfb.h ${S} || true
23         cp ${STAGING_KERNEL_DIR}/include/linux/omapfb.h ${S} || true
24         oe_runmake -e
25 }
26
27 do_install() {
28         install -d ${D}/${bindir}
29         install -m 0755 ${S}/omapfbplay ${D}/${bindir}/
30 }