surpport seeking the recorded video
[vuplus_openembedded] / recipes / ffmpeg / ffmpeg_git.bb
1 require ffmpeg.inc
2
3 DEPENDS += "schroedinger libgsm"
4
5 PE = "1"
6 PV = "0.5.0+${PR}+gitr${SRCREV}" 
7 PR = "r0"
8
9 DEFAULT_PREFERENCE = "-1"
10
11 #FFBRANCH_arm = "arm"
12 FFBRANCH ?= "master"
13
14 # When bumping SRCREV make sure you bump PR here and in dependant recipes (gst-ffmpeg, gnash, omxil, etc) to account for SOVERSION changes
15 SRCREV = "d886804643d7427debfa70d824de7e53ae8e3e83"
16 SRCREV_arm = "d886804643d7427debfa70d824de7e53ae8e3e83"
17 SRCREV_libswscale = "b2e1c8222eeef74b0ca8053b400957dd69e18e4d"
18 SRC_URI = "git://git.mansr.com/ffmpeg.mru;protocol=git;branch=${FFBRANCH} \
19 "
20
21 S = "${WORKDIR}/git"
22 B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
23
24 FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations  -ftree-vectorize -fomit-frame-pointer -O4 -ffast-math"
25 BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
26
27 EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
28 EXTRA_FFCONF ?= ""
29
30 EXTRA_OECONF = " \
31         --enable-shared \
32         --enable-pthreads \
33         --disable-stripping \
34         --enable-gpl \
35         --enable-nonfree \
36         --enable-postproc \
37         \
38         --cross-prefix=${TARGET_PREFIX} \
39         --prefix=${prefix} \
40         \
41         --enable-x11grab \
42         --enable-libfaac \
43         --enable-libfaad \
44         --enable-libfaadbin \
45         --enable-libgsm \
46         --enable-libmp3lame \
47         --enable-libschroedinger \
48         --enable-libtheora  \
49         --enable-libvorbis \
50         --arch=${TARGET_ARCH} \
51         --enable-cross-compile \
52         --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
53         --extra-ldflags="${TARGET_LDFLAGS}" \
54         --enable-hardcoded-tables \
55         ${EXTRA_FFCONF} \
56 "
57
58 do_configure() {
59         sed -i -e s:'check_cflags -std=c99'::g ${S}/configure
60         cd ${S}
61         git clone git://git.mplayerhq.hu/libswscale || true
62         cd libswscale
63         git checkout ${SRCREV_libswscale} || true
64         cd ${S}
65         mkdir -p ${B}
66         cd ${B}
67         ${S}/configure ${EXTRA_OECONF}
68                 sed -i -e s:Os:O4:g ${B}/config.h
69 }
70