surpport seeking the recorded video
[vuplus_openembedded] / recipes / ezx / ezx-boot-usb-native_svn.bb
1 DESCRIPTION = "Boot a Motorola EZX device with a user supplied kernel"
2 DEPENDS = "virtual/libusb0-native virtual/kernel"
3 SECTION = "devel"
4 AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
5 LICENSE = "GPL"
6 PV = "0.3.0+svnr${SRCPV}"
7
8 SRC_URI = "svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http" 
9 S = "${WORKDIR}/boot_usb"
10
11 EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
12
13 inherit autotools native
14
15 do_deploy() {
16         install -d ${DEPLOY_DIR_TOOLS}
17         install -m 0755 boot_usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
18 }
19
20 do_stage() {
21         :
22 }
23
24 do_install() {
25         :
26 }
27
28 addtask deploy before do_build after do_compile