Merge commit 'origin/bug_601_add_missing_meta_package' into opendreambox-1.6
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
4         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
5         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
6         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi"
7 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
8         python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
9         python-pickle gst-plugin-app \
10         gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
11         gst-plugin-typefindfunctions gst-plugin-audioconvert gst-plugin-audioresample \
12         gst-plugin-wavparse python-netclient gst-plugin-mpegstream gst-plugin-selector \
13         gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux \
14         gst-plugin-souphttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
15         gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect \
16         glibc-gconv-iso8859-15 ethtool"
17
18 GST_RTSP_RDEPENDS = "gst-plugin-udp gst-plugin-rtsp gst-plugin-rtp gst-plugin-rtpmanager"
19 GST_ALSA_RDEPENDS = "gst-plugin-alsa alsa-conf"
20 GST_MISC_RDEPENDS = "gst-plugin-matroska gst-plugin-qtdemux gst-plugin-vorbis gst-plugin-audioparsersbad"
21 GST_DVD_RDEPENDS = "gst-plugin-cdxaparse gst-plugin-cdio gst-plugin-vcdsrc"
22 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
23
24 RDEPENDS_append_dm7020 = " gst-plugin-ossaudio gst-plugin-ivorbisdec"
25 RDEPENDS_append_dm7025 = " ${GST_ALSA_RDEPENDS} gst-plugin-ivorbisdec"
26 RDEPENDS_append_dm800 = " ${GST_BASE_RDEPENDS} gst-plugin-ivorbisdec"
27 RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
28 RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
29 RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
30
31 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
32 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
33 #DEPENDS += "enigma2-plugins"
34 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
35
36 DESCRIPTION_append_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
37 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
38 DESCRIPTION_append_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
39 DESCRIPTION_append_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
40 DESCRIPTION_append_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
41 DESCRIPTION_append_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
42 DESCRIPTION_append_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
43 DESCRIPTION_append_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
44 DESCRIPTION_append_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
45 DESCRIPTION_append_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
46 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
47 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "twisted-web"
48 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "twisted-web"
49 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
50 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
51 DESCRIPTION_append_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
52 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "twisted-mail twisted-names python-compression python-mime python-email"
53 DESCRIPTION_append_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
54 DESCRIPTION_append_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
55 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
56 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
57 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
58 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
59
60 PN = "enigma2"
61 PR = "r0"
62
63 SRCDATE = "20100728"
64 #SRCDATE is NOT used by git to checkout a specific revision
65 #but we need it to build a ipk package version
66 #when you like to checkout a specific revision of e2 you need
67 #have to specify a commit id or a tag name in SRCREV
68
69 # if you want upcoming release, use:
70 ####################################################
71 #BRANCH = "master"
72 #PV = "2.8git${SRCDATE}"
73 #SRCREV = ""
74 ####################################################
75
76 # if you want experimental use
77 ####################################################
78 BRANCH = "experimental"
79 PV = "experimental-git${SRCDATE}"
80 SRCREV = ""
81 ####################################################
82
83 # if you want a 2.7-based release, use
84 ####################################################
85 #BRANCH="2.7"
86 #PV = "2.7git${SRCDATE}"
87 # if you want 2.7.0 use
88 #SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
89 ####################################################
90
91 SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV} \
92         file://new-hotplug.patch;patch=1;pnum=1 \
93         file://enigma2.sh"
94
95 S = "${WORKDIR}/git"
96
97 FILES_${PN} += "${datadir}/fonts"
98 FILES_${PN}-meta = "${datadir}/meta"
99 PACKAGES += "${PN}-meta"
100 PACKAGE_ARCH = "${MACHINE_ARCH}"
101
102 inherit autotools pkgconfig
103
104 bindir = "/usr/bin"
105 sbindir = "/usr/sbin"
106
107 EXTRA_OECONF = "--with-target=native --with-libsdl=no"
108
109 do_install_append() {
110         install -m 0755 ${WORKDIR}/enigma2.sh ${D}/usr/bin/
111 }
112
113 python populate_packages_prepend () {
114         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
115
116         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
117 }
118
119 do_stage() {
120         install -d ${STAGING_INCDIR}/enigma2
121         install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}/enigma2
122         for dir in actions base components driver dvb dvb/lowlevel dvb_ci gdi gui mmi nav python service; do
123                 install -d ${STAGING_INCDIR}/enigma2/lib/$dir;
124                 install -m 0644 ${S}/lib/$dir/*.h ${STAGING_INCDIR}/enigma2/lib/$dir;
125         done
126 }