Latest duo2
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
4         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
5         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
6         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi \
7         directfb mpfr gmp tslib opera-hbbtv"
8 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
9         python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
10         python-pickle gst-plugin-app \
11         gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
12         gst-plugin-typefindfunctions gst-plugin-audioconvert gst-plugin-audioresample \
13         gst-plugin-wavparse python-netclient gst-plugin-mpegstream \
14         gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux gst-plugin-dvdsub \
15         gst-plugin-souphttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
16         gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect \
17         glibc-gconv-iso8859-15 ethtool"
18
19 GST_RTSP_RDEPENDS = "gst-plugin-udp gst-plugin-rtsp gst-plugin-rtp gst-plugin-rtpmanager"
20 GST_ALSA_RDEPENDS = "gst-plugin-alsa alsa-conf"
21 GST_MISC_RDEPENDS = "gst-plugin-matroska gst-plugin-isomp4 gst-plugin-vorbis gst-plugin-audioparsers"
22 GST_DVD_RDEPENDS = "gst-plugin-cdxaparse gst-plugin-cdio gst-plugin-vcdsrc"
23 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
24
25 RDEPENDS_append_dm7025 = " ${GST_ALSA_RDEPENDS} gst-plugin-ivorbisdec"
26 RDEPENDS_append_dm800 = " ${GST_BASE_RDEPENDS} gst-plugin-ivorbisdec"
27 RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
28 RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
29 RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
30 RDEPENDS_append_bm750 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
31 RDEPENDS_append_vusolo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
32 RDEPENDS_append_vuuno = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
33 RDEPENDS_append_vuultimo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
34 RDEPENDS_append_vu7425 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
35 RDEPENDS_append_vuduo2 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
36 RDEPENDS_append_vusolo2 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
37 RDEPENDS_append_dm7020hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
38
39 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
40 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
41 #DEPENDS += "enigma2-plugins"
42 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
43
44 DESCRIPTION_append_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
45 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
46 DESCRIPTION_append_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
47 DESCRIPTION_append_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
48 DESCRIPTION_append_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
49 DESCRIPTION_append_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
50 DESCRIPTION_append_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
51 DESCRIPTION_append_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
52 DESCRIPTION_append_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
53 DESCRIPTION_append_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
54 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
55 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "twisted-web"
56 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "twisted-web"
57 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
58 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
59 DESCRIPTION_append_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
60 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "twisted-mail twisted-names python-compression python-mime python-email"
61 DESCRIPTION_append_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
62 DESCRIPTION_append_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
63 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
64 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
65 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
66 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslansetup = "configure wireless lan"
67 RDEPENDS_enigma2-plugin-systemplugins-wirelesslansetup = "wpa-supplicant wireless-tools python-wifi"
68 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
69 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
70 RDEPENDS_enigma2-plugin-extensions-hbbtv = "tslib-conf libts-1.0-0 libsysfs2 directfb libgmp3 libmpfr1 opera-hbbtv"
71
72 PN = "enigma2"
73 PR = "r1"
74
75 SRCDATE = "20110922"
76 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
77 #SRCDATE is NOT used by git to checkout a specific revision
78 #but we need it to build a ipk package version
79 #when you like to checkout a specific revision of e2 you need
80 #have to specify a commit id or a tag name in SRCREV
81
82 # if you want experimental use
83 ####################################################
84 BRANCH = "experimental"
85 PV = "experimental-git${SRCDATE}"
86 #SRCREV = ""
87 ####################################################
88
89 # if you want a 2.7-based release, use
90 ####################################################
91 #BRANCH="2.7"
92 #PV = "2.7git${SRCDATE}"
93 # if you want 2.7.0 use
94 #SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
95 ####################################################
96
97 # if you want a vuplus release, use
98 ####################################################
99 #BRANCH_vuplus = "vuplus"
100 #PV_vuplus = "2.8git${SRCDATE}"
101 #SRCREV_vuplus = "4186f8c308d9450353520a88eb5a5ee3940281d3"
102 ####################################################
103
104 #if you want a vuplus experimental, use
105 ####################################################
106 BRANCH_vuplus = "vuplus_experimental"
107 PV_vuplus = "experimental-git${SRCDATE}"
108 SRCREV_vuplus = ""
109 ####################################################
110
111 #SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
112 #SRC_URI_append_dm7025 = " file://7025_pvr_device_compatibility.diff;patch=1;pnum=1"
113
114 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
115
116
117 SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
118            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
119            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
120            file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
121            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
122            file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
123            file://enigma2-hbbtv_20120604.patch;patch=1;pnum=1 \
124            file://MyriadPro-Regular.otf \
125            file://MyriadPro-Semibold.otf \
126            file://MyriadPro-SemiboldIt.otf \
127            file://750S \
128            file://Vu_HD \
129            file://number_key \
130            "
131
132 SRC_URI_append_bm750 = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
133 SRC_URI_append_vuuno = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
134
135 SRC_URI_append_vusolo = " file://enigma2_vuplus_misc.patch;patch=1;pnum=1"
136
137 SRC_URI_append = " ${@base_contains("MACHINE_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
138
139 SRC_URI_append_vuultimo = " \
140            file://analog.ttf \
141            file://skin_user.xml \
142            file://vfd_icons \
143 "
144 SRC_URI_append_vu7425 = " \
145            file://analog.ttf \
146            file://skin_user.xml \
147            file://vfd_icons \
148 "
149
150 def change_po():
151         import os
152         try:
153                 os.system("find ./ -name \"*.po\" > ./po_list")
154                 os.system("find ./ -name \"*.pot\" >> ./po_list")
155                 po_list = []
156                 po_list = open('po_list','r+').readlines()
157                 for x in po_list:
158                         changeword(x)
159                 os.system('rm po_list')
160         except:
161                 print 'word patch error '
162                 return
163
164 def changeword(file):
165         fn = file[:-1]
166         fnn = file[:-1]+'_n'
167         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
168         os.system(cmd)
169         cmd1 = "mv "+fnn+" "+fn
170         os.system(cmd1)
171
172 do_unpack_append(){
173         change_po()
174 }
175
176 S = "${WORKDIR}/git"
177
178 FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
179 FILES_${PN}-meta = "${datadir}/meta"
180 PACKAGES += "${PN}-meta"
181 PACKAGE_ARCH = "${MACHINE_ARCH}"
182
183 inherit autotools pkgconfig
184
185
186 do_compile_prepend_vuplus() {
187         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
188         install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
189         install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
190         install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
191         install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
192         install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
193         install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
194         install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
195         install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
196         install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
197         install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
198         install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
199         install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
200         install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
201         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
202 }
203
204 EXTRA_OECONF = " \
205         ${@base_contains("MACHINE_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
206         ${@base_contains("MACHINE_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
207         ${@base_contains("MACHINE_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
208         ${@base_contains("MACHINE_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
209         BUILD_SYS=${BUILD_SYS} \
210         HOST_SYS=${HOST_SYS} \
211         STAGING_INCDIR=${STAGING_INCDIR} \
212         STAGING_LIBDIR=${STAGING_LIBDIR} \
213 "
214
215 do_install_append_vuultimo() {
216         install -m 0755 ${WORKDIR}/analog.ttf ${D}/usr/share/fonts/
217         install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
218         install -d ${D}/usr/share/enigma2/vfd_icons/
219         install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
220 }
221
222 python populate_packages_prepend () {
223         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
224
225         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
226 }
227
228 RCONFLICTS_${PN} = "dreambox-keymaps"
229 RREPLACES_${PN} = "dreambox-keymaps tuxbox-tuxtxt-32bpp (<= 0.0+cvs20090130-r1)"
230
231 # workaround for opkg <= 0.1.7+svnr455-r19.1
232 pkg_preinst_${PN} () {
233         if [ "x$D" != "x" ]; then
234                 exit 1
235         fi
236         if [ -f ${datadir}/fonts/tuxtxt.ttf ]; then
237                 cp -a ${datadir}/fonts/tuxtxt.ttf /tmp/tuxtxt.ttf
238         fi
239 }
240 pkg_postinst_${PN} () {
241         if [ "x$D" != "x" ]; then
242                 exit 1
243         fi
244         if [ -f /tmp/tuxtxt.ttf -a ! -f ${datadir}/fonts/tuxtxt.ttf ]; then
245                 mv /tmp/tuxtxt.ttf ${datadir}/fonts/tuxtxt.ttf
246         fi
247 }