use rc-keyboard on ultimo
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
4         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
5         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
6         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi"
7 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
8         python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
9         python-pickle gst-plugin-app \
10         gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
11         gst-plugin-typefindfunctions gst-plugin-audioconvert gst-plugin-audioresample \
12         gst-plugin-wavparse python-netclient gst-plugin-mpegstream \
13         gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux gst-plugin-dvdsub \
14         gst-plugin-souphttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
15         gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect \
16         glibc-gconv-iso8859-15 ethtool"
17
18 GST_RTSP_RDEPENDS = "gst-plugin-udp gst-plugin-rtsp gst-plugin-rtp gst-plugin-rtpmanager"
19 GST_ALSA_RDEPENDS = "gst-plugin-alsa alsa-conf"
20 GST_MISC_RDEPENDS = "gst-plugin-matroska gst-plugin-isomp4 gst-plugin-vorbis gst-plugin-audioparsers"
21 GST_DVD_RDEPENDS = "gst-plugin-cdxaparse gst-plugin-cdio gst-plugin-vcdsrc"
22 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
23
24 RDEPENDS_append_dm7025 = " ${GST_ALSA_RDEPENDS} gst-plugin-ivorbisdec"
25 RDEPENDS_append_dm800 = " ${GST_BASE_RDEPENDS} gst-plugin-ivorbisdec"
26 RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
27 RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
28 RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
29 RDEPENDS_append_bm750 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
30 RDEPENDS_append_vusolo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
31 RDEPENDS_append_vuuno = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
32 RDEPENDS_append_vuultimo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
33 RDEPENDS_append_dm7020hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
34
35 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
36 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
37 #DEPENDS += "enigma2-plugins"
38 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
39
40 DESCRIPTION_append_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
41 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
42 DESCRIPTION_append_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
43 DESCRIPTION_append_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
44 DESCRIPTION_append_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
45 DESCRIPTION_append_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
46 DESCRIPTION_append_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
47 DESCRIPTION_append_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
48 DESCRIPTION_append_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
49 DESCRIPTION_append_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
50 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
51 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "twisted-web"
52 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "twisted-web"
53 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
54 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
55 DESCRIPTION_append_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
56 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "twisted-mail twisted-names python-compression python-mime python-email"
57 DESCRIPTION_append_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
58 DESCRIPTION_append_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
59 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
60 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
61 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
62 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslansetup = "configure wireless lan"
63 RDEPENDS_enigma2-plugin-systemplugins-wirelesslansetup = "wpa-supplicant wireless-tools python-wifi"
64 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
65 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
66
67 PN = "enigma2"
68 PR = "r0"
69
70 SRCDATE = "20110922"
71 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
72 #SRCDATE is NOT used by git to checkout a specific revision
73 #but we need it to build a ipk package version
74 #when you like to checkout a specific revision of e2 you need
75 #have to specify a commit id or a tag name in SRCREV
76
77 # if you want experimental use
78 ####################################################
79 BRANCH = "experimental"
80 PV = "experimental-git${SRCDATE}"
81 #SRCREV = ""
82 ####################################################
83
84 # if you want a 2.7-based release, use
85 ####################################################
86 #BRANCH="2.7"
87 #PV = "2.7git${SRCDATE}"
88 # if you want 2.7.0 use
89 #SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
90 ####################################################
91
92 # if you want a vuplus release, use
93 ####################################################
94 #BRANCH_vuplus = "vuplus"
95 #PV_vuplus = "2.8git${SRCDATE}"
96 #SRCREV_vuplus = "4186f8c308d9450353520a88eb5a5ee3940281d3"
97 ####################################################
98
99 #if you want a vuplus experimental, use
100 ####################################################
101 BRANCH_vuplus = "vuplus_experimental"
102 PV_vuplus = "experimental-git${SRCDATE}"
103 SRCREV_vuplus = ""
104 ####################################################
105
106 #SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
107 #SRC_URI_append_dm7025 = " file://7025_pvr_device_compatibility.diff;patch=1;pnum=1"
108
109 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
110
111
112 SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
113            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
114            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
115            file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
116            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
117            file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
118            file://MyriadPro-Regular.otf \
119            file://MyriadPro-Semibold.otf \
120            file://MyriadPro-SemiboldIt.otf \
121            file://750S \
122            file://Vu_HD \
123            file://number_key \
124            "
125
126 SRC_URI_append_bm750 = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
127 SRC_URI_append_vuuno = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
128
129 SRC_URI_append_vusolo = " file://enigma2_vuplus_misc.patch;patch=1;pnum=1"
130
131 SRC_URI_append = " ${@base_contains("MACHINE_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
132
133 SRC_URI_append_vuultimo = " \
134            file://orbitron-medium.ttf \
135            file://skin_user.xml"
136
137 def change_po():
138         import os
139         try:
140                 os.system("find ./ -name \"*.po\" > ./po_list")
141                 os.system("find ./ -name \"*.pot\" >> ./po_list")
142                 po_list = []
143                 po_list = open('po_list','r+').readlines()
144                 for x in po_list:
145                         changeword(x)
146                 os.system('rm po_list')
147         except:
148                 print 'word patch error '
149                 return
150
151 def changeword(file):
152         fn = file[:-1]
153         fnn = file[:-1]+'_n'
154         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
155         os.system(cmd)
156         cmd1 = "mv "+fnn+" "+fn
157         os.system(cmd1)
158
159 do_unpack_append(){
160         change_po()
161 }
162
163 S = "${WORKDIR}/git"
164
165 FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
166 FILES_${PN}-meta = "${datadir}/meta"
167 PACKAGES += "${PN}-meta"
168 PACKAGE_ARCH = "${MACHINE_ARCH}"
169
170 inherit autotools pkgconfig
171
172
173 do_compile_prepend_vuplus() {
174         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
175         install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
176         install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
177         install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
178         install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
179         install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
180         install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
181         install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
182         install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
183         install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
184         install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
185         install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
186         install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
187         install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
188         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
189 }
190
191 EXTRA_OECONF = " \
192         ${@base_contains("MACHINE_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
193         ${@base_contains("MACHINE_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
194         ${@base_contains("MACHINE_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
195         ${@base_contains("MACHINE_FEATURES", "remote-keyboard", "--with-remote-keyboard" , "", d)} \
196         BUILD_SYS=${BUILD_SYS} \
197         HOST_SYS=${HOST_SYS} \
198         STAGING_INCDIR=${STAGING_INCDIR} \
199         STAGING_LIBDIR=${STAGING_LIBDIR} \
200 "
201
202 do_install_append_vuultimo() {
203         install -m 0755 ${WORKDIR}/orbitron-medium.ttf ${D}/usr/share/fonts/
204         install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
205 }
206
207 python populate_packages_prepend () {
208         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
209
210         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
211 }
212
213 RCONFLICTS_${PN} = "dreambox-keymaps"
214 RREPLACES_${PN} = "dreambox-keymaps tuxbox-tuxtxt-32bpp (<= 0.0+cvs20090130-r1)"
215
216 # workaround for opkg <= 0.1.7+svnr455-r19.1
217 pkg_preinst_${PN} () {
218         if [ "x$D" != "x" ]; then
219                 exit 1
220         fi
221         if [ -f ${datadir}/fonts/tuxtxt.ttf ]; then
222                 cp -a ${datadir}/fonts/tuxtxt.ttf /tmp/tuxtxt.ttf
223         fi
224 }
225 pkg_postinst_${PN} () {
226         if [ "x$D" != "x" ]; then
227                 exit 1
228         fi
229         if [ -f /tmp/tuxtxt.ttf -a ! -f ${datadir}/fonts/tuxtxt.ttf ]; then
230                 mv /tmp/tuxtxt.ttf ${datadir}/fonts/tuxtxt.ttf
231         fi
232 }