Merge branch 'vuplus-1.6' of 192.168.102.66:/var/ikseong/repo/openembedded into vuplu...
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
4         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
5         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
6         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi"
7 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
8         python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
9         python-pickle gst-plugin-app \
10         gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
11         gst-plugin-typefindfunctions gst-plugin-audioconvert gst-plugin-audioresample \
12         gst-plugin-wavparse python-netclient gst-plugin-mpegstream \
13         gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux gst-plugin-dvdsub \
14         gst-plugin-souphttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
15         gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect \
16         glibc-gconv-iso8859-15 ethtool"
17
18 GST_RTSP_RDEPENDS = "gst-plugin-udp gst-plugin-rtsp gst-plugin-rtp gst-plugin-rtpmanager"
19 GST_ALSA_RDEPENDS = "gst-plugin-alsa alsa-conf"
20 GST_MISC_RDEPENDS = "gst-plugin-matroska gst-plugin-qtdemux gst-plugin-vorbis gst-plugin-audioparsersbad"
21 GST_DVD_RDEPENDS = "gst-plugin-cdxaparse gst-plugin-cdio gst-plugin-vcdsrc"
22 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
23
24 RDEPENDS_append_dm7025 = " ${GST_ALSA_RDEPENDS} gst-plugin-ivorbisdec"
25 RDEPENDS_append_dm800 = " ${GST_BASE_RDEPENDS} gst-plugin-ivorbisdec"
26 RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
27 RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
28 RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
29 RDEPENDS_append_bm750 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
30 RDEPENDS_append_vusolo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
31 RDEPENDS_append_dm7020hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
32
33 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
34 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
35 #DEPENDS += "enigma2-plugins"
36 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
37
38 DESCRIPTION_append_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
39 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
40 DESCRIPTION_append_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
41 DESCRIPTION_append_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
42 DESCRIPTION_append_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
43 DESCRIPTION_append_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
44 DESCRIPTION_append_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
45 DESCRIPTION_append_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
46 DESCRIPTION_append_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
47 DESCRIPTION_append_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
48 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
49 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "twisted-web"
50 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "twisted-web"
51 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
52 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
53 DESCRIPTION_append_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
54 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "twisted-mail twisted-names python-compression python-mime python-email"
55 DESCRIPTION_append_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
56 DESCRIPTION_append_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
57 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
58 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
59 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
60 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
61
62 PN = "enigma2"
63 PR = "r0"
64
65 SRCDATE = "20110217"
66 SRCDATE_vuplus = "20110217"
67 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
68 #SRCDATE is NOT used by git to checkout a specific revision
69 #but we need it to build a ipk package version
70 #when you like to checkout a specific revision of e2 you need
71 #have to specify a commit id or a tag name in SRCREV
72
73 # if you want experimental use
74 ####################################################
75 BRANCH = "experimental"
76 PV = "experimental-git${SRCDATE}"
77 #SRCREV = ""
78 ####################################################
79
80 # if you want a 2.7-based release, use
81 ####################################################
82 #BRANCH="2.7"
83 #PV = "2.7git${SRCDATE}"
84 # if you want 2.7.0 use
85 #SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
86 ####################################################
87
88 # if you want a vuplus release, use
89 ####################################################
90 #BRANCH_vuplus = "vuplus"
91 #PV_vuplus = "2.8git${SRCDATE}"
92 #SRCREV_vuplus = "4186f8c308d9450353520a88eb5a5ee3940281d3"
93 ####################################################
94
95 #if you want a vuplus experimental, use
96 ####################################################
97 BRANCH_vuplus = "vuplus_experimental"
98 PV_vuplus = "experimental-git${SRCDATE}"
99 SRCREV_vuplus = ""
100 ####################################################
101
102 SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
103 SRC_URI_append_dm7025 = " file://7025_pvr_device_compatibility.diff;patch=1;pnum=1"
104
105 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
106 # enigma2_vuplus_mediaplayer_unpause.patch is for work-around of gstreamer bug 
107
108
109 SRC_URI_bm750 = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
110            file://enigma2_vuplus_duo.patch;patch=1;pnum=1 \
111            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
112            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
113            file://enigma2_vuplus_mediaplayer_unpause.patch;patch=1;pnum=1 \
114            file://MyriadPro-Regular.otf \
115            file://MyriadPro-Semibold.otf \
116            file://MyriadPro-SemiboldIt.otf \
117            file://750S \
118            file://Vu_HD \
119            file://number_key \
120            "
121
122 SRC_URI_vusolo = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
123            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
124            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
125            file://enigma2_vuplus_mediaplayer_unpause.patch;patch=1;pnum=1 \
126            file://enigma2_vuplus_misc.patch;patch=1;pnum=1 \
127            file://MyriadPro-Regular.otf \
128            file://MyriadPro-Semibold.otf \
129            file://MyriadPro-SemiboldIt.otf \
130            file://750S \
131            file://Vu_HD \
132            file://number_key \
133            "
134
135 def change_po():
136         import os
137         try:
138                 os.system("find ./ -name \"*.po\" > ./po_list")
139                 os.system("find ./ -name \"*.pot\" >> ./po_list")
140                 po_list = []
141                 po_list = open('po_list','r+').readlines()
142                 for x in po_list:
143                         changeword(x)
144                 os.system('rm po_list')
145         except:
146                 print 'word patch error '
147                 return
148
149 def changeword(file):
150         fn = file[:-1]
151         fnn = file[:-1]+'_n'
152         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
153         os.system(cmd)
154         cmd1 = "mv "+fnn+" "+fn
155         os.system(cmd1)
156
157 do_unpack_append(){
158         change_po()
159 }
160
161 S = "${WORKDIR}/git"
162
163 FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
164 FILES_${PN}-meta = "${datadir}/meta"
165 PACKAGES += "${PN}-meta"
166 PACKAGE_ARCH = "${MACHINE_ARCH}"
167
168 inherit autotools pkgconfig
169
170
171 do_compile_prepend_vuplus() {
172         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
173         install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
174         install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
175         install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
176         install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
177         install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
178         install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
179         install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
180         install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
181         install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
182         install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
183         install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
184         install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
185         install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
186         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
187 }
188
189 EXTRA_OECONF = " \
190         BUILD_SYS=${BUILD_SYS} \
191         HOST_SYS=${HOST_SYS} \
192         STAGING_INCDIR=${STAGING_INCDIR} \
193         STAGING_LIBDIR=${STAGING_LIBDIR} \
194 "
195
196 python populate_packages_prepend () {
197         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
198
199         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
200 }
201
202 RCONFLICTS_${PN} = "dreambox-keymaps"
203 RREPLACES_${PN} = "dreambox-keymaps tuxbox-tuxtxt-32bpp (<= 0.0+cvs20090130-r1)"
204
205 # workaround for opkg <= 0.1.7+svnr455-r19.1
206 pkg_preinst_${PN} () {
207         if [ "x$D" != "x" ]; then
208                 exit 1
209         fi
210         if [ -f ${datadir}/fonts/tuxtxt.ttf ]; then
211                 cp -a ${datadir}/fonts/tuxtxt.ttf /tmp/tuxtxt.ttf
212         fi
213 }
214 pkg_postinst_${PN} () {
215         if [ "x$D" != "x" ]; then
216                 exit 1
217         fi
218         if [ -f /tmp/tuxtxt.ttf -a ! -f ${datadir}/fonts/tuxtxt.ttf ]; then
219                 mv /tmp/tuxtxt.ttf ${datadir}/fonts/tuxtxt.ttf
220         fi
221 }