Merge branch 'vuplus-1.6k_dev' into vuplus-1.6k
[vuplus_openembedded] / recipes / enigma2 / enigma2-plugins.bb
1 DESCRIPTION = "Additional plugins for Enigma2"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3
4 PACKAGES_DYNAMIC = "enigma2-plugin-*"
5
6 # if you want experimental, use:
7 #SRCREV="87fd2f1120962f553ecb1a88bbee46ed821df975"
8 SRCREV="c8fc96e8e51e1ef71e1709f9dd6f733007f9463e"
9 SRCDATE="20110215"
10 BRANCH="master"
11 PV = "experimental-git${SRCDATE}"
12
13 PR = "r6"
14 SRC_URI="git://code.vuplus.com/git/dvbapp-plugin.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
15
16 EXTRA_OECONF = " \
17         BUILD_SYS=${BUILD_SYS} \
18         HOST_SYS=${HOST_SYS} \
19         STAGING_INCDIR=${STAGING_INCDIR} \
20         STAGING_LIBDIR=${STAGING_LIBDIR} \
21 "
22
23 SRC_URI_append_vuplus = " \
24            file://enigma2_plugins_mytube_tpm.patch;patch=1;pnum=1 \
25            file://enigma2_plugins_20121113.patch;patch=1;pnum=1 \
26            file://enigma2_plugins_webinterface_tpm.patch;patch=1;pnum=1 \
27            file://enigma2_plugins_ac3lipsync_dolby.patch;patch=1;pnum=1 \
28            file://enigma2_plugins_autoresolution_fix.patch;patch=1;pnum=1 \
29            file://enigma2_plugins_dependency.patch;patch=1;pnum=1 \
30            file://dreamboxweb.png \
31            file://dreamboxwebtv.png \
32            file://favicon.ico"
33
34 FILES_${PN} += " /usr/share/enigma2 /usr/share/fonts "
35 FILES_${PN}-meta = "${datadir}/meta"
36 PACKAGES += "${PN}-meta"
37 PACKAGE_ARCH = "${MACHINE_ARCH}"
38
39 inherit autotools
40
41 S = "${WORKDIR}/git"
42
43 DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen python-daap"
44 DEPENDS += "enigma2"
45 DEPENDS += "enigma2-plugin-extensions-openwebif"
46 DEPENDS += "enigma2-plugin-systemplugins-adsm"
47
48 def modify_po():
49         import os
50         try:
51                 os.system("find ./ -name \"*.po\" > ./po_list")
52                 os.system("find ./ -name \"*.pot\" >> ./po_list")
53                 po_list = []
54                 po_list = open('po_list','r+').readlines()
55                 for x in po_list:
56                         changeword1(x)
57                 changeword1('enigma2-plugins/networkwizard/src/networkwizard.xml ')
58                 changeword2('enigma2-plugins/webinterface/src/web-data/tpl/default/index.html ')
59                 os.system('rm po_list')
60         except:
61                 print 'word patch error '
62                 return
63
64 def changeword1(file):
65         fn = file[:-1]
66         fnn = file[:-1]+'_n'
67         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
68         os.system(cmd)
69         cmd1 = "mv "+fnn+" "+fn
70         os.system(cmd1)
71
72 def changeword2(file):
73         fn = file[:-1]
74         fnn = file[:-1]+'_n'
75         cmd = "sed s/Dreambox/Vu+/g "+fn+" > "+fnn
76         os.system(cmd)
77         cmd1 = "mv "+fnn+" "+fn
78         os.system(cmd1)
79
80 do_unpack_append(){
81         modify_po()
82 }
83
84
85 do_install_append_vuplus() {
86         install -m 0644 ${WORKDIR}/dreamboxweb.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
87         install -m 0644 ${WORKDIR}/dreamboxwebtv.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/tpl/default/streaminterface/img
88         install -m 0644 ${WORKDIR}/favicon.ico ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
89 }
90
91 python populate_packages_prepend () {
92         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
93
94         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', 'Enigma2 Plugin: %s', recursive=True, match_path=True, prepend=True)
95
96         def getControlLines(mydir, d, package):
97                 import os
98                 try:
99                         #ac3lipsync is renamed since 20091121 to audiosync.. but rename in cvs is not possible without lost of revision history..
100                         #so the foldername is still ac3lipsync
101                         if package == 'audiosync':
102                                 package = 'ac3lipsync'
103                         src = open(mydir + package + "/CONTROL/control").read()
104                 except IOError:
105                         return
106                 for line in src.split("\n"):
107                         if line.startswith('Package: '):
108                                 full_package = line[9:]
109                         if line.startswith('Depends: '):
110                                 bb.data.setVar('RDEPENDS_' + full_package, ' '.join(line[9:].split(', ')), d)
111                         if line.startswith('Description: '):
112                                 bb.data.setVar('DESCRIPTION_' + full_package, line[13:], d)
113                         if line.startswith('Replaces: '):
114                                 bb.data.setVar('RREPLACES_' + full_package, ' '.join(line[10:].split(', ')), d)
115                         if line.startswith('Conflicts: '):
116                                 bb.data.setVar('RCONFLICTS_' + full_package, ' '.join(line[11:].split(', ')), d)
117                         if line.startswith('Maintainer: '):
118                                 bb.data.setVar('MAINTAINER_' + full_package, line[12:], d)
119
120         mydir = bb.data.getVar('D', d, 1) + "/../git/"
121         for package in bb.data.getVar('PACKAGES', d, 1).split():
122                 getControlLines(mydir, d, package.split('-')[-1])
123 }