surpport seeking the recorded video
[vuplus_openembedded] / recipes / dtnrg / dtn_2.5.0.bb
1 DESCRIPTION = "Delay Tolerant Networking Package"
2 HOMEPAGE = "http://www.dtnrg.org/wiki"
3 SECTION = "libs"
4 DEPENDS = "db openssl python-native xerces-c"
5 LICENSE = "Apache"
6 PR = "r5"
7
8 # thread code atomic ops do not play with thumb
9 ARM_INSTRUCTION_SET = "arm"
10
11 SRC_URI = "\
12   http://www.dtnrg.org/docs/code/dtn_${PV}.tgz \
13   file://configure_fix.patch;patch=1 \
14 "
15
16 inherit autotools distutils-base
17
18 EXTRA_OECONF = "\
19   --with-python=${STAGING_BINDIR_NATIVE}/python \
20   --with-db=${STAGING_DIR_HOST}${layout_exec_prefix} \
21   --with-tcl=${STAGING_DIR_HOST}${layout_exec_prefix} \
22   --without-google-perftools \
23   --without-bluez \
24   --without-bonjour \
25   --with-expat=${STAGING_DIR_HOST}${layout_exec_prefix} \
26   --with-xerces-c=${STAGING_DIR_HOST}${layout_exec_prefix} \
27   --without-tclreadline \
28   --with-zlib=${STAGING_DIR_HOST}${layout_exec_prefix} \
29   --without-xsd-tool \
30   --with-db=${STAGING_DIR_HOST}${layout_exec_prefix} \
31   --enable-ecl \
32   --enable-edp \
33   --without-mysql \
34   --without-postgres \
35   --with-openssl=${STAGING_DIR_HOST}${layout_exec_prefix} \
36 "
37
38 export BUILD_SYS
39 export HOST_SYS
40
41 do_configure_prepend() {
42         for i in aclocal/*.ac oasys/aclocal/*.ac; do
43                 install -m 0644 $i ${STAGING_DATADIR}/aclocal/`basename $i`.m4
44         done
45         autotools_do_configure
46 }
47
48 do_install_append() {
49         cd applib/python
50         INCDIR=../.. LIBDIR=.. VERSION=${PV} python setup.py install --prefix=${D}/${prefix} --install-data=${D}/${datadir}
51 }
52
53 PACKAGES =+ "${PN}-lib"
54 FILES_${PN}-lib = "${libdir}/*.so*"
55 PACKAGES += "python-dtn"
56 DESCRIPTION_python-dtn = "Python bindings to the DTN API"
57 PR_python-dtn = "ml4"
58 FILES_python-dtn = "${libdir}/${PYTHON_DIR}"
59 RDEPENDS_python-dtn = "python-core dtn-lib"
60
61 FILES_${PN}-dbg += "\
62   ${libdir}/${PYTHON_DIR}/site-packages/.debug \
63   ${libdir}/.debug \
64   ${bindir}/.debug \
65 "
66
67 FILES_${PN} += "${sysconfdir}"