surpport seeking the recorded video
[vuplus_openembedded] / recipes / dreambox / dreambox-dvbincludes.bb
1 DESCRIPTION = "This package provides dbox2/dreambox \
2 compatible header files for the API to the drivers."
3
4 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
5
6 SRC_URI = "http://sources.dreamboxupdate.com/snapshots/include2.tar.gz"
7 S = "${WORKDIR}/include"
8
9 ALLOW_EMPTY_dreambox-dvbincludes = "1"
10
11 INPUT_FILES = "input_fake.h ci/ci.h  dbox/avia_gt_pig.h dbox/avs_core.h \
12         dbox/event.h dbox/fp.h dbox/info.h dbox/lcd.h dbox/saa7126_core.h \
13         dbox/lcd-ks0713.h dbox/fb.h \
14         dreambox/dreaminfo.h \
15         tuxbox/hardware_dbox2.h tuxbox/hardware_dreambox.h tuxbox/hardware_pci.h \
16         tuxbox/info.h tuxbox/info_dbox2.h tuxbox/kernel.h"
17
18 INPUT_FILES_OST =       " ost/audio.h ost/ca.h ost/demux.h ost/descrambler.h ost/dmx.h \
19         ost/dvb.h ost/dvb_frontend.h  ost/frontend.h ost/net.h ost/sec.h \
20         ost/video.h "
21
22 PV="1"
23
24 do_install_powerpc() {
25         install -d ${STAGING_INCDIR}/ci
26         install -d ${STAGING_INCDIR}/dbox
27         install -d ${STAGING_INCDIR}/dreambox
28         install -d ${STAGING_INCDIR}/ost
29         install -d ${STAGING_INCDIR}/tuxbox
30         for f in ${INPUT_FILES} ${INPUT_FILES_OST}; do
31                 install -m 0644 ${S}/$f ${STAGING_INCDIR}/$f
32         done;
33 }
34
35 do_install_mipsel() {
36         install -d ${STAGING_INCDIR}/ci
37         install -d ${STAGING_INCDIR}/dbox
38         install -d ${STAGING_INCDIR}/dreambox
39         install -d ${STAGING_INCDIR}/tuxbox
40         for f in ${INPUT_FILES}; do
41                 install -m 0644 ${S}/$f ${STAGING_INCDIR}/$f
42         done;
43 }
44