[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / djvulibre / djvulibre_3.5.21.bb
1 DESCRIPTION = "DjVuLibre is an open source (GPL'ed) implementation of DjVu, including viewers, browser plugins, decoders, simple encoders, and utilities."
2 LICENSE = "GPL"
3 DEPENDS = "jpeg libpng tiff"
4
5 SRC_URI = "${SOURCEFORGE_MIRROR}/djvu/djvulibre-${PV}.tar.gz \
6            file://fix-cross-configure.patch;patch=1"
7
8 inherit qt4x11 autotools pkgconfig
9
10 #export QT_LIBS = "${OE_QMAKE_LIBS_QT}"
11 #export QT_CFLAGS = "${OE_QMAKE_CXXFLAGS} -I${QTDIR}/include/Qt/ "
12
13 EXTRA_OECONF = " --enable-threads \
14                  --with-qt=${QTDIR} "
15
16 do_configure() {
17         gnu-configize
18         autoreconf
19         oe_runconf
20         for i in $(find ${S} -name "Makefile") ; do
21                 sed -i -e s:-L/usr/lib::g $i
22         done
23 }
24
25 do_stage() {
26         autotools_stage_all
27 }
28
29 PACKAGES =+ "libdjvulibre"
30 FILES_libdjvulibre = "${libdir}/libdjvulibre.so.*"
31 FILES_${PN} += "${datadir}/djvu"