surpport seeking the recorded video
[vuplus_openembedded] / recipes / diethotplug / diethotplug_0.4.bb
1 SECTION = "base"
2 LICENSE = "GPL"
3 DESCRIPTION = "A small, C implementation of hotplug."
4
5 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/diethotplug-${PV}.tar.gz \
6            file://modules.usbmap \
7            file://modules.pcimap \
8            file://modules.ieee1394map"
9
10 export KLIBC = ""
11
12 do_compile () {
13         perl convert_usb.pl ${WORKDIR}/modules.usbmap > usb_modules.h
14         perl convert_pci.pl ${WORKDIR}/modules.pcimap > pci_modules.h
15         perl convert_ieee1394.pl ${WORKDIR}/modules.ieee1394map > ieee1394_modules.h
16         oe_runmake
17 }
18
19 do_install () {
20         install -d ${D}${sbindir}
21         install -m 0755 hotplug ${D}${sbindir}/
22 }