surpport seeking the recorded video
[vuplus_openembedded] / recipes / cron / cron_3.0pl1.bb
1 SECTION = "base"
2 DESCRIPTION = "Vixie cron."
3 LICENSE = "cron"
4 PR ="r8"
5
6 SRC_URI = "http://ibiblio.org/pub/Linux/system/daemons/cron/cron${PV}.tar.gz \
7            file://nonrootinstall.patch;patch=1 \
8            file://time.patch;patch=1 \
9            file://init"
10 S = "${WORKDIR}/cron${PV}"
11
12 INITSCRIPT_NAME = "cron"
13 INITSCRIPT_PARAMS = "defaults"
14 inherit update-rc.d
15
16 CFLAGS_append = " -I${S} -DSYS_TIME_H=0"
17 do_install () {
18         install -d ${D}${sbindir} ${D}${bindir}
19         install -d ${D}${sysconfdir}/init.d/
20         install -d ${D}/var/cron/tabs
21         install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/cron
22         oe_runmake 'DESTDIR=${D}' install
23         chmod ugo+rx ${D}${sbindir}/* ${D}${bindir}/*
24 }
25 pkg_postinst() {
26         update-rc.d cron defaults 65
27 }
28
29 pkg_postrm() {
30         update-rc.d cron remove
31 }
32
33