surpport seeking the recorded video
[vuplus_openembedded] / recipes / classpath / inetlib_1.1.1.bb
1 DESCRIPTION = "A Java library of clients for common internet protocols"
2 LICENSE = "GPL + library exception"
3 AUTHOR = "GNU Classpath"
4 HOMEPAGE = "http://gnu.org/software/classpath/inetlib.html"
5
6 SRC_URI = "\
7   http://ftp.gnu.org/gnu/classpath/${BP}.tar.gz \
8   file://datadir_java.patch;patch=1 \
9   "
10
11 inherit java-library autotools
12
13 DEPENDS = "fastjar-native"
14
15 JPN = "libgnuinet-java"
16
17 export JAVAC = "javac"
18
19 export JAVA = "java"
20
21 # We fake this, it is not neccessary anyway.
22 export JAVADOC = "true"
23
24 do_compile() {
25   oe_runmake JARDIR=${datadir_java} inetlib_jar=${JARFILENAME}
26 }
27
28 do_install_append() {
29   java_install
30 }