surpport seeking the recorded video
[vuplus_openembedded] / recipes / classpath / classpath-native_0.98.bb
1 require classpath-native.inc
2
3 # Deadlocks occur on at least amd64 hosts.
4 DEFAULT_PREFERENCE = "-1"
5
6 PR = "r3"
7
8 # The code affected by the javanet-local patch
9 # is usually not compiled. However if someone changes
10 # to --enable-local-sockets it will.
11 SRC_URI += "\
12   file://SimpleName.diff;patch=1;pnum=0 \
13   file://sun-security-getproperty.patch;patch=1;pnum=0 \
14   file://ecj_java_dir.patch;patch=1 \
15   file://autotools.patch;patch=1 \
16   file://miscompilation.patch;patch=1 \
17   file://toolwrapper-exithook.patch;patch=1 \
18   "
19
20 do_unpackpost() {
21   # Kind of patch: Moves package "org.w3c.dom.html2" to "org.w3c.dom.html"
22         mv external/w3c_dom/org/w3c/dom/html2 \
23                         external/w3c_dom/org/w3c/dom/html
24
25         find examples/gnu/classpath/examples/html gnu/xml/dom/html2 external/w3c_dom/org/w3c/dom/html -name "*.java" \
26                 -exec sed -i -e"s|org.w3c.dom.html2|org.w3c.dom.html|" {} \;
27
28         sed -i -e"s|org/w3c/dom/html2|org/w3c/dom/html|" external/w3c_dom/Makefile.am
29 }
30
31 addtask unpackpost after do_unpack before do_patch
32