surpport seeking the recorded video
[vuplus_openembedded] / recipes / cherokee / cherokee_0.4.29.bb
1 # Cherokee web server
2 DESCRIPTION = "Cherokee Web Server fast and secure"
3 LICENSE = "GPL"
4 SECTION = "network"
5 DEPENDS = "openssl libpcre"
6 SRC_URI = "http://www.0x50.org/download/0.4/${PV}/${P}.tar.gz \
7           file://configure.patch;patch=1 \
8           file://Makefile.in.patch;patch=1 \
9           file://Makefile.cget.patch;patch=1 \
10           file://util.patch;patch=1"
11 PR = "${INC_PR}.0"
12
13 inherit autotools
14
15 LEAD_SONAME = "libcherokee-base"
16
17 EXTRA_OECONF = "--enable-tls=openssl --disable-static --disable-nls"
18
19 do_configure() {
20         gnu-configize
21         oe_runconf
22 }
23
24 do_install_prepend () {
25         $BUILD_CC -DHAVE_SYS_STAT_H -o cherokee_replace cherokee_replace.c
26 }