surpport seeking the recorded video
[vuplus_openembedded] / recipes / cdparanoia / cdparanoia_9.8alpha.bb
1 # cdparanoia OE build file
2 # Copyright (C) 2005, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4 LICENSE = "GPL"
5
6 PR = "r3"
7
8 SRC_URI = "http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-alpha9.8.src.tgz \
9          file://fixes.patch;patch=1 \
10          file://Makefile.patch;patch=1"
11
12 S = "${WORKDIR}/cdparanoia-III-alpha9.8"
13
14 inherit autotools
15
16 PARALLEL_MAKE = ""
17
18 do_install() {
19         oe_runmake BINDIR="${D}/usr/bin" MANDIR="${D}/usr/share/man/" \
20                    INCLUDEDIR="${D}/usr/include/" LIBDIR="${D}/usr/lib" install
21 }
22 do_stage() {
23         install -d ${STAGING_INCDIR} ${STAGING_LIBDIR}
24         install -m 0644 paranoia/cdda_paranoia.h ${STAGING_INCDIR}
25         install -m 0644 interface/cdda_interface.h ${STAGING_INCDIR}
26         oe_libinstall -C interface libcdda_interface ${STAGING_LIBDIR}
27         oe_libinstall -C paranoia libcdda_paranoia ${STAGING_LIBDIR}
28 }
29