surpport seeking the recorded video
[vuplus_openembedded] / recipes / cacao / cacao-initial_0.98.bb
1 require cacao-native.inc
2
3 PROVIDES = "virtual/java-initial"
4
5 DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial jikes-initial"
6
7 PR = "r0"
8
9 SRC_URI = "\
10         http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2; \
11         file://cacao-0.98-initial.patch;patch=1;pnum=1 \
12         "
13
14 # libjvm disabled - it would conflict with cacao-native installations
15 EXTRA_OECONF = "\
16     --enable-debug \
17     --with-classpath-libdir=${libdir} \
18     --with-classpath-includedir=${includedir}/classpath-initial \
19     --with-classpath-classes=${datadir}/classpath-initial/glibj.zip \
20     --with-vm-zip=${datadir}/cacao-initial/vm.zip \
21     --program-suffix=-initial \
22     --disable-libjvm \
23     "
24
25 # enforces the usage of jikes-initial
26 export JAVAC=jikes-initial
27
28 # enforces the usage of fastjar
29 export JAR=fastjar
30
31 do_configure_append() {
32   # Fix the executable name in the wrapper script.
33   sed -i -e "s|exec cacao|exec cacao-initial|" src/scripts/java.in
34 }