surpport seeking the recorded video
[vuplus_openembedded] / recipes / busybox / busybox_1.13.2.bb
1 require busybox.inc
2 PR = "${INC_PR}.1"
3
4 SRC_URI = "\
5   http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
6   file://busybox-1.13.2-awk.patch;patch=1 \
7   file://busybox-1.13.2-depmod.patch;patch=1 \
8   file://busybox-1.13.2-init.patch;patch=1 \
9   file://busybox-1.13.2-killall.patch;patch=1 \
10   file://busybox-1.13.2-mdev.patch;patch=1 \
11   file://busybox-1.13.2-modprobe.patch;patch=1 \
12   file://busybox-1.13.2-printf.patch;patch=1 \
13   file://busybox-1.13.2-syslogd.patch;patch=1 \
14   file://busybox-1.13.2-tar.patch;patch=1 \
15   file://busybox-1.13.2-top24.patch;patch=1 \
16   file://busybox-1.13.2-unzip.patch;patch=1 \
17   file://busybox-1.13.2-wget.patch;patch=1 \
18   \
19   file://udhcpscript.patch;patch=1 \
20   file://udhcpc-fix-nfsroot.patch;patch=1 \
21   file://B921600.patch;patch=1 \
22   file://get_header_tar.patch;patch=1 \
23   file://busybox-appletlib-dependency.patch;patch=1 \
24   file://find-touchscreen.sh \
25   file://busybox-cron \
26   file://busybox-httpd \
27   file://busybox-udhcpd \
28   file://default.script file://simple.script \
29   file://hwclock.sh \
30   file://mount.busybox \
31   file://mountall \
32   file://syslog \
33   file://syslog.conf \
34   file://umount.busybox \
35   file://defconfig \
36   file://mdev \
37   file://mdev.conf \
38 "
39
40 EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
41
42 do_configure_prepend () {
43         if [ "${TARGET_ARCH}" = "avr32" ] ; then
44                 sed -i s:CONFIG_FEATURE_OSF_LABEL=y:CONFIG_FEATURE_OSF_LABEL=n: ${WORKDIR}/defconfig
45         fi
46 }
47
48 do_install_append() {
49     install -m 0644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
50     install -d ${D}${sysconfdir}/init.d/
51     install -d ${D}${sysconfdir}/mdev
52     install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
53     install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
54 }