surpport seeking the recorded video
[vuplus_openembedded] / recipes / apache / apache_2.0.54.bb
1 SECTION = "net"
2 DEPENDS = "openssl expat libpcre"
3
4 PR = "r4"
5
6 # ------------------------------------------
7 # NOTE: This package is currently only meant
8 # to be built nativly on the target device
9 # ------------------------------------------
10
11 SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.gz \
12            "
13
14 S = "${WORKDIR}/httpd-${PV}"
15
16 inherit autotools update-rc.d
17
18 INITSCRIPT_NAME = "apache"
19 INITSCRIPT_PARAMS = "defaults 91 20"
20
21 CONFFILES_${PN} = "${sysconfdir}/apache/httpd.conf \
22                    ${sysconfdir}/apache/ssl.conf \
23                    ${sysconfdir}/apache/magic \
24                    ${sysconfdir}/apache/mime.types \
25                    ${datadir}/apache/htdocs/index.html \
26                    ${datadir}/apache/htdocs/apache_pb.gif \
27                   "
28
29 PACKAGES = "${PN}-dbg libaprutil libapr apache-dev apache-doc apache"
30 FILES_libapr = "${libdir}/libapr*.so.0* ${libdir}/apr.exp"
31 FILES_libaprutil = "${libdir}/libaprutil*.so.0* ${libdir}/aprutil.exp"
32
33 FILES_apache-dev_prepend = "${datadir}/apache/build ${bindir}/apr-config ${bindir}/apu-config "
34 FILES_apache-doc_prepend = "${datadir}/apache/manual "
35
36 FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
37                ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
38                ${datadir}/apache"
39
40 CFLAGS_append = " -DPATH_MAX=4096"
41 CFLAGS_prepend = "-I${STAGING_INCDIR}/openssl "
42 EXTRA_OECONF = "--enable-ssl \
43                 --with-ssl=${STAGING_LIBDIR}/.. \
44                 --enable-dav \
45                 --enable-dav-fs \
46                 --with-dbm=sdbm \
47                 --with-berkeley-db=no \
48                 --localstatedir=${localstatedir}/log/apache \
49                 --with-gdbm=no \
50                 --with-ndbm=no \
51                 --datadir=${datadir}/apache \
52                 --sysconfdir=${sysconfdir}/apache \
53                 "
54
55 export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
56
57 do_configure () {
58         # Looks like rebuilding configure doesn't work, so we are skipping
59         # that and are just using the shipped one
60         oe_runconf
61 }
62
63 do_install_append () {
64         set -x
65         rm ${D}/${datadir}/apache/htdocs/index*
66         rm ${D}/${datadir}/apache/htdocs/apache_pb2.*
67         rm ${D}/${datadir}/apache/htdocs/apache_pb.png
68         install -m 0644 ${FILESDIR}/index.html ${D}/${datadir}/apache/htdocs/
69
70         install -d ${D}/${sysconfdir}/init.d
71         cat ${FILESDIR}/init | \
72                 sed -e 's,/usr/sbin/,${sbindir}/,g' \
73                     -e 's,/usr/bin/,${bindir}/,g' \
74                     -e 's,/usr/lib,${libdir}/,g' \
75                     -e 's,/etc/,${sysconfdir}/,g' \
76                     -e 's,/usr/,${prefix}/,g' > ${D}/${sysconfdir}/init.d/apache
77         chmod 755 ${D}/${sysconfdir}/init.d/apache
78
79         install -m 0644 ${FILESDIR}/httpd.conf ${D}/${sysconfdir}/apache/httpd.conf
80
81         rm ${D}/${libdir}/libexpat.*
82 }
83
84 python () {
85     # Don't build apache unless we are building nativly
86     target = bb.data.getVar("TARGET_ARCH", d, 1)
87     build = bb.data.getVar("BUILD_ARCH", d, 1)
88     if target != build:
89         raise bb.parse.SkipPackage("Apache will only build nativly (TARGET_ARCH == BUILD_ARCH)")
90 }
91