surpport seeking the recorded video
[vuplus_openembedded] / recipes / angstrom / angstrom-led-config.bb
1 DESCRIPTION = "Configuration files for runtime LED configuration" 
2
3 #PV = "${DISTRO_VERSION}"
4 PR = "r7"
5 PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7 inherit update-rc.d
8 INITSCRIPT_NAME = "led-config"
9 INITSCRIPT_PARAMS = "defaults 05"
10
11 SRC_URI = "file://led-config \
12            file://leds \
13           "     
14
15 do_compile() {
16         :
17 }
18
19
20 do_install () {
21         install -d ${D}/${sysconfdir}/default
22         install -d ${D}/${INIT_D_DIR}
23
24         install -m 0644 ${WORKDIR}/leds ${D}/${sysconfdir}/default/
25         install -m 0755 ${WORKDIR}/led-config ${D}/${INIT_D_DIR}
26 }
27
28 CONFFILES_${PN} += "${sysconfdir}/default/leds \
29                     ${INIT_D_DIR}/led-config \
30                    "
31