surpport seeking the recorded video
[vuplus_openembedded] / recipes / altboot / altboot_1.0.8.bb
1 require altboot.inc
2
3 PR = "r4"
4
5 TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '-')}"
6 SRC_URI = "svn://hentges.net/public/altboot/tags/;module=${TAG};proto=svn"
7 S = "${WORKDIR}/${TAG}/"
8
9 do_install() {
10         install -d ${D}/sbin
11         install -d ${D}/etc/altboot-menu
12         install -d ${D}/etc/altboot-menu/Advanced
13         install -d ${D}/etc/altboot.rc
14         install -d ${D}/usr/share/doc/altboot
15         install -d ${D}/usr/share/sounds
16
17         if test -d ${S}/${MACHINE}
18         then
19                 install -m 0644 ${S}/${MACHINE}/altboot*.cfg ${D}/etc
20         else
21                 install -m 0644 ${S}/altboot*.cfg ${D}/etc
22         fi
23
24         install -m 0644 ${S}/beep.raw ${D}/usr/share/sounds
25         install -m 0644 ${S}/altboot.func ${D}/etc
26         install -m 0755 ${S}/init.altboot ${D}/sbin
27
28         install -m 0755 ${S}/altboot-menu/*-* ${D}/etc/altboot-menu
29
30         install -m 0755 ${S}/altboot-menu/Advanced/*-* ${D}/etc/altboot-menu/Advanced
31
32         install -m 0755 ${S}/altboot.rc/*.sh ${D}/etc/altboot.rc
33         install -m 0644 ${S}/altboot.rc/*.txt ${D}/etc/altboot.rc
34 }
35
36 do_configure() {
37         cat ${S}/init.altboot | sed "s/^VERSION=.*/VERSION=\"${PV}\"/" > ${S}/init.altboot_
38         mv ${S}/init.altboot_ ${S}/init.altboot
39 }
40
41 pkg_postinst_${PN}() {
42         update-alternatives --install /sbin/init init /sbin/init.altboot 55
43 }
44
45 pkg_postrm_${PN}() {
46         update-alternatives --remove init /sbin/init.altboot
47 }
48
49 PACKAGE_ARCH_${PN} = "all"