checksums.ini: fix writenfi-mipsel-2.6.18-r1 checksum
[vuplus_openembedded] / recipes / alsa / alsa-lib_1.0.20.bb
1 DESCRIPTION = "Alsa sound library"
2 HOMEPAGE = "http://www.alsa-project.org"
3 SECTION = "libs/multimedia"
4 LICENSE = "LGPL"
5 PR = "r3"
6
7 # configure.in sets -D__arm__ on the command line for any arm system
8 # (not just those with the ARM instruction set), this should be removed,
9 # (or replaced by a permitted #define).
10 #FIXME: remove the following
11 ARM_INSTRUCTION_SET = "arm"
12
13 SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
14            file://fix-tstamp-declaration.patch;patch=1 \
15            file://fix_libmath.patch;patch=1 \
16           "
17 SRC_URI_append_opendreambox = " file://asound.conf"
18
19 inherit autotools pkgconfig
20
21
22 EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python --enable-shared --enable-static"
23
24
25 require alsa-fpu.inc
26 EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
27
28
29 require alsa-versym.inc
30 EXTRA_OECONF += "${@get_alsa_versym_setting(bb, d)} "
31
32
33 do_stage () {
34         autotools_stage_all
35 }
36
37 do_install_append_opendreambox() {
38         install -d ${D}${sysconfdir}
39         install -m 0644 ${WORKDIR}/asound.conf ${D}${sysconfdir}/asound.conf
40 }
41
42 PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
43 FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*"
44 FILES_libasound = "${libdir}/libasound.so.*"
45 FILES_alsa-server = "${bindir}/*"
46 FILES_alsa-conf = "${datadir}/alsa/"
47 FILES_alsa-conf_opendreambox = "${datadir}/alsa/ ${sysconfdir}/asound.conf"
48 FILES_alsa-dev += "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*"
49 FILES_alsa-conf-base = "\
50 ${datadir}/alsa/alsa.conf \
51 ${datadir}/alsa/cards/aliases.conf \
52 ${datadir}/alsa/pcm/default.conf \
53 ${datadir}/alsa/pcm/dmix.conf \
54 ${datadir}/alsa/pcm/dsnoop.conf"
55
56 RDEPENDS_libasound = "alsa-conf-base"