surpport seeking the recorded video
[vuplus_openembedded] / recipes / alsa / alsa-lib_1.0.11.bb
1 DESCRIPTION = "Alsa sound library"
2 HOMEPAGE = "http://www.alsa-project.org"
3 SECTION = "libs/multimedia"
4 LICENSE = "LGPL"
5 PR = "r4"
6
7 # configure.in sets -D__arm__ on the command line for any arm system
8 # (not just those with the ARM instruction set), this should be removed,
9 # (or replaced by a permitted #define).
10 #FIXME: remove the following
11 ARM_INSTRUCTION_SET = "arm"
12
13 SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2"
14
15 inherit autotools pkgconfig
16
17 EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes"
18
19 do_stage() {
20         oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
21         install -d ${STAGING_INCDIR}/alsa/sound
22         install -m 0644 include/*.h ${STAGING_INCDIR}/alsa/
23         install -m 0644 include/sound/ainstr*.h ${STAGING_INCDIR}/alsa/sound/
24         install -d ${STAGING_DATADIR}/aclocal
25         install -m 0644 utils/alsa.m4 ${STAGING_DATADIR}/aclocal/
26 }
27
28 PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
29 FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*"
30 FILES_libasound = "${libdir}/libasound.so*"
31 FILES_alsa-server = "${bindir}/*"
32 FILES_alsa-conf = "${datadir}/alsa/"
33 FILES_alsa-dev = "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*"
34 FILES_alsa-conf-base = "\
35 ${datadir}/alsa/alsa.conf \
36 ${datadir}/alsa/cards/aliases.conf \
37 ${datadir}/alsa/pcm/default.conf \
38 ${datadir}/alsa/pcm/dmix.conf \
39 ${datadir}/alsa/pcm/dsnoop.conf"
40
41 RDEPENDS_libasound = "alsa-conf-base"